Problem with build in unreal

someone know what do I need to do in order to fix this problem? :
Error MSB3075 The command ““F:\Program Files (x86)\Epic Games\4.12\Engine\Build\BatchFiles\Build.bat” BuildingEscapeEditor Win64 Development “F:\UnrealProjects\BuildingEscape\BuildingEscape\BuildingEscape.uproject” -waitmutex” exited with code 5. Please verify that you have sufficient rights to run this command. BuildingEscape C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets.
I cant build anything and I tried to run visual studio as administrator

I had a similar problem once. I needed to log out of visual studio and re-enter my credentials. Maybe that will work in your case? You probably already solved this, but just in case for the future, sometimes vs just needs you to log out and log in again to work.

Sadly this did not resolve the error for me. I’m under the impression that this error has something to do with OnlineSubsystem but I have no idea what.

Edit: Holy cow, mine was caused by SessionInterface.IsValid instead of SessionInterface.IsValid().

I spent almost half day to search for the solution to this.Finally, I found something useful.

You can refer these two links above. Both the same, either one will be fine.

For your convenient, I copyed it :

This is a known issue with changing to 4.12 and using tasks. It can be resolved by simply adding “GameplayTasks” to the PublicDependencyModuleNames section inside your ‘ProjectName’.Build.cs For example:

PublicDependencyModuleNames.AddRange(new string[] { “Core”, “CoreUObject”, “Engine”, “InputCore”, “AIModule”, “GameplayTasks” });

Add GameplayTasks to PublicDependencyModuleNames of the YourProjectName.Build.cs file~.

When you see that in the console at the bottom, click the “Output” instead of “Error list”. When you’re on that tab, you’ll have a message that is easier to understand.

1 Like

This is what saved me (checking the Output tab)! Thank you.

Privacy & Terms