Problem with baking cloth (multires originally)

I have the same problem with all the cloth objects (all multires originally).

Baking multires didn’t work for me, so I converted everything to lp+hp pair, making sure to apply the base before applying the multires on hp.

On the normal map most of the items appear more or less ok, although with glitches. The cavity map though stays black for all of the objects. I tried different values for extrusion and max ray distance (from 0.005m to 1m) and combinations of thereof. I tried duplicating the lp model, scaling it a bit and using as cage. Nothing works for me.

At this point I feel hopeless :grinning_face_with_smiling_eyes: , if anyone have ideas what I could try, I would be very happy.

Thanks

1 Like

Could it be, that while trying to make it work with the multi-res, but abandoning the process while doing so you’ve accidentally still copied, and linked incorrect properties?

  • Like the baked image may not be connected to anything while baking?
  • Did you save the bitmap(s)?
  • So many things could go wrong! In 3.2. multi-res should work so maybe the error starts there!
  • Don’t forget that the Orc body and clothing probably have different mesh densities, so they need different properties.
  • Did you apply the scale to the clothes?
2 Likes

You have cage tricked, and I doubt you are using a cage. perhaps this is the cause?

1 Like

Thank you for the support and suggestions.

I couldn’t make it work, so I went through the baking process from the very beginning. In the end I made it work, it looks agreeable. What bothers me is that I don’t understand how the process work, so it is just tweaking parameters often with no much understanding. I will share my findings.

I noticed that my belt lp (low poly) is much bigger than its hp (high poly) version. So I manually tweaked the lp to much hp closer. The baking worked after this. I thought the “apply base” should do it right, but in my case it didn’t work well.

Strangely enough, I didn’t update UV after changing the lp mesh. (The lp/hp version of the belt with the multres still on is on the screenshots)

For the back loin cloth I forgot to bring Level Viewport option to the available maximum. After I did this, baking worked fine. Almost, there was a glitch that I couldn’t resolve.

The rest of the cloths worked fine this time. The main difference is that I used only extrusion parameter in the bake menu this time.

My general observation is that lp should be bigger than its hp version so as to contain it within. Although it works if hp sticks out a little bit through the lp in some places.

If the lp too big compared to its hp counterpart, then baking doesn’t work (neither extrusion, nor max ray distance, nor combination of thereof didn’t make it for me).

I am a little bit disappointed, because I want to understand how the process works instead of just tweaking things until the result is good. But I am happy that I went through it over again and got to success! It is a very, very good practice.

Thank you for help!

Belt multires (lp is much bigger than hp)


Finally, success!


3 Likes

Well done working through it and solving the issues.
Yes the two Lp and Hp need to be as near identical in size as possible. Ray distance and extrusion only extend the ‘copying’ short distances.

Baking is a lot of parameters to remember and get right. It is annoying in some ways that there is not some ‘auto’ system that works all the parameters out for you, Bake this onto that, Go. Done!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.