Problem setting up IDE - setting up VS Code in Unreal

My code in VS is not appearing in the in game terminal. I’m pretty certain I’ve following all the instructions correctly in lesson 44. When I proceed with lesson 46 however the changes I’m making to the VS code are not then reflected in the game.

My setup seems correct. When I click to “Open Visual Studio Code” my VS application loads and I can select the BullCowCartridge.cpp and the BullCowCartridge.h files. I can see that BullCowCartridge.cpp file has my amended code.

I’m also remembering to save any changes to the VS Code, and to compile when I’m back in Unreal, but it makes no difference when I press Play. So at the moment I can’t even see my changes to the Welcome text.

Is there a bug? Or some vital setting I’m missing?


Did you try restarting the Unreal editor? Sometimes hotreloading doesn’t work so you need to restart the editor.

Thanks for your suggestion. I’ve found the solution. I had completely missed lesson 45 “Actors and Components”, so I had never setup the terminal with the BullCowCartridge. All working now.

That had me completely stumped. It got my brain working trying to think what the problem was, so probably all part of the learning experience!

Great course by the way. I’m really enjoying it.


That’s not your fault. For some reason, somehow, that lecture got unpublished. :man_shrugging:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms