Problem making object stick to the ground

So i’ve been trying for an hour making the rocketship stick to the ground, chaning the pivot point but I just can’t make it work. I am fairly noob when it comes to software and computers in general so the problem probably lies withing my skill level. anyways, the rocketship’s position is x:0, y:0, z:0 so I don’t understand why it is still hovering.

I can of course drag the ship down, BUT if I drag a new ship into the scene from my asset it will hover above the ground which is my problem.

If anyone here know the solution and can help me out, that would be very appreciated. :slight_smile:


What you have selected in the screenshot are the child GameObjects of the main Rocket GameObject, if you select just the parent RocketShip GameObject in the Hierarchy, what is the Y position in the Transform component?

BUT if I drag a new ship into the scene from my asset it will hover above the ground which is my problem.

When you say “drag a new ship into the scene” I’m assuming you mean dragging your Rocketship prefab? Assuming so, check the Y position on the Transform component on that also.

Also, what is the position of the landing pad? For example, are you certain the issue lies with the rocket and isn’t just a case of the landing pad isn’t in the correct place to meet it?

Nice rocket by the way, reminds me of Thunderbird 1 :slight_smile:

@Rob Hi, yes when I select the parent Rocketship , either from under the game scene (left side) or as a prefab, the Y position is 0 but the rocketship is still hovering above the ground (which also is Y position=0).

Thanks for you nice comment on my ship and such a short reply time :slight_smile:

1 Like


You’re welcome.

Ok, so did you check the position of the landing pad?

Assuming the landing pad isn’t the problem, you could re-align by either removing the children from the parent, select all of them and set them where you want them, then, create a new GameObject to be the parent, and drag them in. It doesn’t really matter if the Transform positions are adjusted on the child GameObjects, as it’ll be the parent one which you will be most likely referencing and making changes to it’s position. Or, just select all of the child GameObjects and adjust their position, leaving the parent GameObject at 0,0,0.

Also, before making any of these suggested changes, take a copy of your project first, just in case things don’t quite work out and you want to get back to where you were easily. I adopt a Teflon Technique with my support… nothing sticks :wink:

If you are still running in to problems after giving the above ago I will be happy to take a quick look for you, would just need you to zip up your project files and share them. The forum will allow uploads of up to 10mb, if you project files are larger than that then you can use a service such as Google Drive or Dropbox and share the URL.

1 Like


Hey again,

So I did what you said and removed the parent-object, re-aligned the children and put them in a new gameobject. Now it works as it should and the problem is solved ! :smiley:

Thank you so much for helping me out and the super quick responding, cheers!

1 Like

Great, glad that has resolved the problem for you, plus you’ll know what to do if you encounter it again, or see someone else post with the same issue :slight_smile:

Enjoy the rest of the course.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms