Problem exporting lamp fbx to Unreal Editor - no animation and physics

Hi,

I’ve had a lot of problems exporting from blender 2.91 to Unreal Engine 4.25 with the settings shown in the course video. Problems included no animation and no physics.

The first problem with missing animations I finally just figured out when writing this post was that blender doesn’t export the animation when the armature is set to rest position. While I was troubleshooting yesterday I had set it to rest position and not changed it back. Doh!

For the physics I spent ages playing around and reading forums and can get the model into UE with physics if I do the following: 1) move my model to align to the world origin at its rest position; 2) set blender units to metres and unit scale to 0.01; 3) scale the mesh and armature by x100 and apply those transforms; 4) scale the animation values (in the graph editor) by x100 on the y axis.

If I don’t do these steps the Unreal Editor import complains about the bones being too small (see error message below) and doesn’t create the Physics properties that Mike shows in the video. However the animation comes through okay without doing those steps.


This is all a bit of a faff, and Mike doesn’t have to do this in the video. Why does this work for Mike without having to do these units fixes?

I’ve attached a link to a zip file with two blend files and fbx’s, with and without the units fixes I described above. Note for future readers of this thread this link will only be up for a short time while I’m figuring this out - I will add any resolution to this thread if I find it.
lamp fbx export

My blender export options are shown in the attached image. The Unreal Editor import settings are default except for changing to animated time.

Thanks, Pete.

I have no experience in exporting to game engines.
But Michael, the previous tutor, uses 2.79 Blender I believe?
So things could have been changed since then.
There are more people with export problems, bone direction related.
Maybe search in these forums on .fbx?

1 Like

I have not tried it yet, but there is an addon for this:

2 Likes

Hi guys, thanks for the suggestions.

The export video tutorial is using blender 2.80.75, newer than the 2.7x series but older than current. Could be a version issue but I’ve read about people having this same issue in versions earlier and later than the one Mike uses. Also fortunately I haven’t got a problem with bone directions!

The UE addons I’ve also read about, but having watched their intro videos and reading a few forum discussions on the Unreal Editor forums my understanding is that they don’t support blender animation or armatures (directions and scaling) properly yet so I don’t think they will help and haven’t tried them.

Thanks, Pete.

1 Like

I really, really would like a course in exporting Blender characters to unreal.

1 Like

I’m amazed there isn’t that much on the internet about it that covers all the issues. A lot of forum posts I found describing issues didn’t have any answers, or had various suggestions that didn’t work (or worked for some people and not others). From what I gather there is some issue with units where UE uses cm as its default unit whereas blender is metres. The scaling by x100 (and then by x0.01 to offset it) is to account for that metre to cm conversion I believe. My fixes above were based on some of the posts I found and seem to work (for me at least!). But I’ve watched the course video multiple times and can’t see why it works for Mike without the fixes. So I assume that it is something I’ve messed up or an important step I missed along the way.

Pete.

now ive never used unreal heh, so probaby well out of my depth.
but, managed to get rid of a few errors.

on the FBX importer, UE side. selecting “use T0 as ref pose” gets rid of some bone errors.

im just looking into the bone weight error, that looks to be coming from the shade handle bone, but ill keep digging

2 Likes

Older version of Blender can still be downloaded. And you can have several versions on your machine!

In the past, I had many strange computer software related issues.
No info found the internet.
Problem was almost:

  • Did I ask the correct questions, label, keywords
  • Or the problem was very very specific for my situation, because of my own doing so.

I just downloaded the same Blender version as the one in the course video (2.80.75) to rule out the Blender version. Unfortunately the same thing still happens.

I have only exported characters from blender to unreal to learn the animation system in Unreal, so I haven’t look up the physic system (colliders), but I haven’t had any problem. First I import the T-position with the mesh and without the animation, and then export only the animation. No error from the bones sizes.

I think I will find all those problems when I will try to integrate the animations to the game-play but, for now, it works for me.