Prefab view is different to Rick's Path(0) with nested waypoints


Loving the course and Rick’s delivery. I even purchased a second monitor and wall mounted it so I can view the tutorial videos on one screen as I type along on another. This lecture is the first time I’ve been stumped by something not matching what Rick has on screen.

Has the latest Unity update (December 18, 2018.3) changed the way Prefabs are presented?

I have created the Path (0) prefab as Rick did but I no longer have the > icon to the right of the prefab when looking in the Assets/Prefab folder. That means I cannot copy the three waypoints to the enemyPathing script serialized field list attached the to enemy ship prefab.

When I open my enemy ship prefab the list elements are empty. I can attach to the instanced ship game object as the hierarchy lists the waypoints but if I try to attach them to the prefab the hierarchy view changes to the ‘new’ hierarchy detail view for the ship game object and I lose the view of the Path (0) and nested waypoint objects. I have tried locking the inspector to the ship prefab view but every time I click on hierarchy the inspector changes despite being locked.

When I view the ship prefab in the inspector the list elements are empty even if I have applied them from the instanced ship object. Clicking the circle icon to search for elements to add results in blanks.

However, I can add waypoints to the list for the instanced ship object. I have then applied all to save that to the prefab but the prefab still shows as missing transforms. Even if I delete the prefab and copy the instanced ship object from the scene hierarchy the waypoint transforms disappear when I view the prefab in the inspector.

I cannot break the cycle of the new prefab detail view altering what is displayed in the hierarchy when I click on Path (0).

By the way, the code executes perfectly with the instanced ship game object as the enemy follows the waypoints. I’ve even increased the list count size and added more waypoints.

1 Like

Hi Alan,

Yes. Significantly.

See also;

1 Like

Hi Rob,

Thanks for the links. I followed the video and applied the override, then applied all but the prefab did not update and the instanced object list elements remained in bold.

I deleted the prefab, and dragged the scene ship object to make a new prefab but then the newly formed prefab has an empty list again. The scene ship’s list elements become bold, even though all I have done is create a prefab from it. I’m pretty confused as to why.

I think tomorrow I will delete the ship game object entirely and start with a fresh GameObject to see if that makes a difference.

1 Like

I’m having the same issue and the fixes you have tried are not working for me as well. At this point I cant continue with the project until a workaround it is found.

Hey Rob,

Once you get to the “Using A Foreach Loop” Lesson it becomes irrelevant since you automate attaching waypoints to prefabs in that episode. Just forge ahead knowing that your code is good and will fix it in a couple of lessons.

1 Like

I found to bypass this you have to drag the Path(0) game object created down to the prefab area. Once it’s down there, double click on it. This will bring up a zoomed in screen of it with the inspector on the right. If you open up the Path (0) hierarchy and drag all of the waypoints down to the prefab area one by one, this successfully creates prefabs for the waypoints that you can attach to the enemy.

Hope this helps anyone that’s been frustrated by that.

Hi, I stompted into the same problem. I cannot add the waypoints to the prefab enemy.
I came to the solution of using the waypoints outside the path (0) game object, I replaced the Path (0) game object prefab for a folder in the Paths folder. So long its working.

I dont think this works anymore

Privacy & Terms