Possible to disable Mist Pass during animation?

Heya; I’m wrapping up G. Abbitt’s Spitfire tutorial, and pushed my animation a bit further from the original parameters; however, I seem to have run into a bit of an issue with trying to complement my scene with a Mist Pass- during my animation, I switch from my 1st camera on the Spitfire to a streetside view of the plane flying overhead. The Mist Pass works splendidly in making the landscape around the town a lot less wonky, but when I switch to the ground camera, my Mist Pass wipes out my .exr background skybox, leaving only a wall of mist. There doesn’t seem to be any options to turn the mist off entirely, only alter its start and end positions- which do not help since the skybox is considered to apparently be beyond the bounds of the rendered scene.

Final render:

Desired result:

1 Like

Compositor mist. Way outside the course. I have never used it. Just watched a YouTube on it. Not sure it will let the background show as the far distance is completely ‘misted’ out. Possibly, if you use an image plane as the sky and set the far distance marker of the mist past it, then it may work as you want.
Or use a colour ramp and change it darker at the end so the mist lightens up far out?

1 Like

Aye, I guess I might have gotten a bit over-enthused over additional bits into the course material (mist, water domains, dual camera swaps). I tried the image plane option, the end result was not optimal. I will see if I can tweak the color ramps accordingly. I find it odd that there’s no apparent way to tweak compositor values during animation.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms