Playstation Dualshock 4 not working?

I am working on Mars Marine and thought I had fixed an issue where the game was not recognising my controller input. Came back to it later and now it doesn’t work any more. I can connect my controller through Steam and have the plugin for Dualshock enabled, but still nothing.

My code seems fine according to the lesson but still nothing. Does Dualshock 5 have this issue? How can I fix?

Have you tried the DS4 Windows app?

Yeah. Odd thing is, it worked once and only once. … not sure why

you connected or using the blue tooth?

Unfortunately no. USB connection. I built this PC and may have forgotten to ensure it had Bluetooth capabilities. LOL

My understanding is PS Controllers can be a bit awkward to set up. I believe there’s a plugin called Windows Dualshock which may help but I really can’t be sure.

I’m having the same issue and can’t seem to find the plugin you’re referencing. Any other ideas? Has anyone out there successfully connected for multiple sessions?

I think i found the plug in you were mentioning! This just worked great for me -

Follow the instructions in this link - embedded within it are the download links for the emulator

1 Like

Uou can get a good USB Bluetooth dongle for about 20 euro and a cheaper one for 5.

Any Mac users figured this out? I hadn’t connected my PS4 controller to my Mac before this class. I’ve been able to bluetooth connect it, couldn’t get any response from UE4. Plugged in via USB, got it work with my Steam account. Still didn’t get UE4 to recognize my controller. Added Playstation touchpad button Y axis and X axis to the Engine-Input Bindings in Project settings. Still no luck. Removed the Gamepad Thumbstick settings. Still not getting anything. I’ve saved every time. Is there a driver or plug in that I need to add? Thank you.

well… I just figured out that I need to press shift+F2 to engage the PS4 controller… got it! sorry about that…

1 Like

Thanks for sharing that. I’m sure others will find this useful.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.