Player character won't move


I am following along with the Crypt Raider tutorial and I’ve run into an issue. I’m in the Character Blueprint section and ever since I deleted the arms mesh from the BP_Player, the player character doesn’t appear to move in-game. I’ve tried:

*Making sure I’ve pressed the 3 dots and picked “Selected Viewport.”
*Reassigning the arms mesh to the BP_Player
*Deleting my BP_Player and recreating a child BP Class from the included BP_FirstPersonCharacter (while also making sure to reassign BP_Player to the GameMode we changed to)
*Assigning Auto-Possess to Player 0 on the BP_Player actor after setting on in the opening scene of the level (I know this wasn’t told to us but I thought it would fix the issue)

I’ve also checked the BP_FirstPersonCharacter and from what I can see, it doesn’t appear to have any input controls for movement or anything else in the blueprint sections of the editor.

(I copy/pasted a snippet to the above so I’m not sure if that actually will upload properly. Apologies in advance if it doesn’t! I’m trying to show a screen grab of the editor for BP_FirstPersonCharacter. I know we’re supposed to have created a child class of this blueprint, but if the original blueprint doesn’t appear to have input controls, I assume that means the child won’t either and that may be the source of my problem.)

I’m not sure what else I can do to fix this. I’ve tried browsing Reddit and this community and none of the fixes there seem to have helped. If it means anything, I’m using Unreal 5.3.2 and have had no other issues with any of the previous tutorials so far. Any help would be greatly appreciated! Thanks in advance!


It appears it’s nothing to do with the player actor and instead seems to have started happening once I changed the game mode. I’m not sure what I’ve done wrong here but I’ll give Google another shot and see if there’s any answers there before reporting back.

Have you had any luck? I found I am encountering the same issues and beginning the google searching to get to the bottom of it.

Hi and sorry for not replying sooner
I have a few questions for you to help guide an answer

When you set up the game mode, did you assign the player character and player controller.

Did you set the game mode to be the default?
Was this game mode C++ code?

Suggestions to fix might be looking again at lecture 46 as it could possibly be a live coding issue.

Try all this and let me know how you get on and we will take it from here.

Hi there!

Don’t ask me to explain why this happened, but this seems to occur with Unreal 5.3 (which I’m also using).

When creating a Game Mode from CryptRaiderGameMode, it doesn’t apply the correct Player Controller Class. You’ll need to go into the Game Mode you created (which will be called BP_CryptRaiderGameMode if you followed the tutorial) and change the Player Controller Class to BP_FirstPersonPlayerController. For me, it was set to PlayerController by default. When I changed it to BP_FirstPersonPlayerController, it worked.

Let me know if you have any luck with that.

1 Like

Thank you so much for this insight! It does seem that this fixed the issue for me!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms