Play from here

For some reason I can’t seem to use the “Play from here” option in the right click menu. Every time I try, it spawns my player in the default player start. Any ideas? I’m using version 4.21 and have tried “current camera location” under the PIE. I’ve also tried deleting my player start with the same results.

Still having this issue?

Not sure about OP but I am currently experiencing the same issue. Currently running on UE 4.23.1. Also tried selecting "Current Camera Location under Play>Spawn Player At settings, as well as deleting the default player start. Still starting at the PlayerPawn’s location, regardles of where I right-click>Play From Here.

Are you using Play from selected viewport or Simulate?

Hey Everyone, :wave:

Unfortunately, I am also experiencing somewhat of a similar issue with 4.20.3. Over here the game always starts at the location where my BP_PlayerPawn is positioned despite me selecting “Play from here”. So basically if I reposition the Pawn to the other end of the map, I will be starting the game in that area.

Some of my settings:

  • On the BP_PlayerPawn’s Details tab Auto Possess Player is set to Player 0,
  • On the World Settings tab GameMode Override is BP_GameMode and Default Pawn Class is BP_PlayerPawn,
  • In the Play Settings the mode is “Selected Viewport” and “Spawn player at…” does not really matter, spawns me at BP_PlayerPawn’s location whatever I choose

I am attaching a screenshot of my BP_PlayerPawn’s Blueprint. Please let me know if sharing anything else might help in pinning down the problem.