Pawn Drift Issue

Not sure if this has been addressed or will be in a future video but i found that if i lock pawn rotation on all 3 axis’s, then it will not occur.

How do you do that?

I guess I should also confirm that I am seeing drifting/floating as well.

I later found that in the next video it was addresses

1 Like

Not only do I have the drifting pawn issue, which I understand will be addressed in the next lesson, but I also have an issue where the pawn doesn’t seem to be able to turn all the way around unless I hit F1 to recenter my cursor.

Or in other words, when my cursor hits the edge of the screen I can’t rotate anymore. Is there an obvious fix to this that I am missing?

I also have an issue with drifting pawn on the floor. It happens mostly when I release grabbed object. When I throw it I am drifting even faster.

And here is the answer (if you don’t want to wait to next video part). You need to set this 3 checks on DefaultPawn_BP blueprint. It will stop player Pawn from rolling.


This fixed the phantom sliding for me, but I still find that when I grab onto the table, I start moving rapidly in one direction. Any ideas?

I have the drift too.
I’m using 4.15 and can’t find those checkboxes

Make sure you click the CollisionComponent first.

Thanks, yes, I’m slow…I got there after a couple more cups of coffee… But like I asked in my other thread - why even use a sphere at all? Why not use a cube? Wouldn’t you just avoid the issue all together then?

1 Like

I guess you could do that as well.

lol many things can cause the cube to topple over aswell but it would be less troublesome. Its interesting this lock rotation will fix it as manually setting the rotation will cause a wierd illusion in 3rd person

Privacy & Terms