Particle Systems not rendering during playmode

So I’m having an issue of my particles systems not rending during playmode and I can not for the life of me figure out why it isn’t working.

I’ve double checked the code against the video as best as I could, other then using a different name for the particle events my code looked the same. The particles will render in the scene view, and in the scene view camera, but will not show during playmode unless I have them set to play on awake.

Can anyone see what I’m missing? Or is there some hidden setting in Unity to display or not display particles. I check the main camera, even went so far as to set the particles on their own layer and made sure the camera had that particle layer set to render. Still nothing…any and all advise welcome! Thanks.

particle issue screen 5


To add to this topic. I have also refactored out the thrustPart.Play() & thrustPart.Stop() into their own methods so I could add a Debug.Log lines into those methods to test and make sure that those specific lines should be firing off and on. It was triggering the methods properly when pressing the space bar. Still no visual in playmode for the particles however.

This is leading me to believe it isn’t a code issue but some setting that is eluding me in Unity.

Checking Unity’s website it seems there have been a lot of instances and many weird fixes that have been tried. None of them has worked for me so I’m just moving on without the shinies in game. I’m 95% sure this is some bug within Unity at this point.

1 Like

I’m also have an issue with this lesson. I have the explosion and victory effects working correctly; However, the issue is with the engine effect.

I set up some print commands next to the effects Play and Stop method and according the console it should be working correctly, but it’s not.

What I did notice as odd was that if I run the game without the Stop method, the particle functions but only when space isn’t being pressed and it’ll continue during the death state as well. So essentially it’s reversed. Then if you add in Stop() then there’s nothing at all.

I just figured out my issue. I’m going to try and explain…

So originally I had the Rocketship in the hierarchy with the particle systems as children. However in the inspector field I linked the particle system prefabs from the assets window. I dragged the actual particle systems from the hierarchy (the children attached to the rocketship in the scene) to the appropriate inspector fields and went into playmode and it worked.

After that I deleted my old rocketship prefab, and recreated the prefab from the ship in the hierarchy. This has seemed to solve my problems.


So after reading Brian_Everts posts, it seems as though my issue is unrelated; However, I did find a solution to my problem of my engine particle not working properly. I received some help on Discord and what we ended up doing was creating an if statement to check the particle status. Once we did this, instead of just calling thrusterEffect.Play(), it worked flawlessly.

if (!thrusterEffect.isPlaying)

Same Problem to me! None oft the particle effects is working! Didn’t found any solution or workaround so far…

OK, the community helped me to fix my problem.

I dragged the particles from the ASSETS window to the script. That was no good idea, because i connected the prefabs with the script. These are not available at runtime, because no instance is created. I have to drag the Particels from the Hierarchy to the Script and everything works fine now!


Thanks that sorted it out for me too. Have to drag from the hierarchy not the prefab.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms