On Mac Unreal editor, unable to select buttons in bottom row of menus/toolbars

NOTE: Please see update below.

I want to use my new iMac for this course as long as possible, because it’s much nicer to use than my old PC, but already I have run into Unreal Launcher bug JIRA [UE-11320], which was reported last year and never resolved. Apparently on certain late model 27" Retina iMacs including mine, when you create a new Unreal project, the interface does not allow you to change the project name. So I have two questions about this.

  1. The work around for this provided by the developer is to clone the project to the desired name, and then delete the original. However, when I tried this, it said the clone feature is not fully supported for code projects, and changes to the source code may be required. I wasn’t able to tell if cloning a brand new code project worked properly or not. Does anyone know if it should, or if not what changes would be required?

  2. I’m not sure how to best report this to the developers, as the original bug report said it was only reported by one person, and they thought it could just be a fluke with his particular computer. I added a comment to the original post for this bug on the Unreal Bugs forum with content similar to this post, but I do not know if that will be seen eventually. What is the protocol for providing additional information for an old, unresolved bug report?

Thank you!

This reads fine, I noticed you said you had an issue posting?

This is the answer I received from Unreal tech support:

“Since we cannot reproduce this on our end we cannot address the issue. In addition to making sure you are running the latest drivers for your GPU, I suggest making a new Blueprint project and cloning that. Then you can add C++ elements after the fact. The only reason it would be an issue is because the cloned version would have different directory paths from the original.”

For the purposes of this course, would making a blueprint project and then adding code allow me to follow along with the videos, or is it already time to switch to the PC? Since my iMac is always on and my PC is not, I tend to put more time into projects that are on my iMac, so I only want to switch if I run into truly painful problems. Thanks.

Not that helpful, have you found a workaround?

No, I haven’t. I’ve never used Unreal Engine before, so I don’t know enough to figure one out on my own. I did extensive searches, and found a lot of unresolved bug reports about the clone tool. There is a Windows work around posted by someone who renames directories by hand to rename a project, but since he is using the Windows directory structure, I don’t know how his workaround would translate to Mac.

So I take it you don’t think creating a Blueprint project, cloning it, and then adding code is a reasonable solution? Perhaps I should just carry on a bit using the default project names until I learn enough to be in a better position to figure out a solution. Also, if I find more Mac bugs, I’ll know not to bother.

Now that I am in Section 3 of the course, I’ve discovered that the Unreal editor does not work at all on my Mac. It keeps trying to select the item above where my mouse is, so I am unable to select anything on a bottom row of buttons. If anyone has heard anything about this, please let me know. In the mean time I am setting up my PC to continue the class on that.

Great, a PC is a much better choice for Unreal anyhow. Good luck!

1 Like

Turns out the problem was caused by a conflict with the Logitech device drivers for a G13 peripheral.

1 Like

Well done solving it :slight_smile:

1 Like

Thanks! The secret was the make a YouTube video to show the Unreal folks. Once they actually saw the problem in action, they could tell right away it was an issue with an input device. Upon hearing this, I slapped my hand to my forehead and unplugged the Logitech gaming peripheral. :wink: (A few years ago I had this sort of problem on PC’s with Logitech mice.)

Privacy & Terms