Not fully able to follow SourceTree lecture

I am finding SourceTree to be extremely challenging to use. I am using Win 7 and my SourceTree layout is quite different to Michael’s.

I do not see any folders, only individual files and, while this is not causing me a problem right now, I can see that it will in the future.

Even getting to this stage is something of a success for me as when I tried to add any folder that already contained data it refused to do so. This must be the most unintuitive piece of software I have ever used.


Send a screen dump.
There are many packages for working with version control. GIT is used a lot as the new way of versioning, but it’s more targeted at source code.
You can do it it also in a simple way, save your work with a version number.
The benefit of using a tools, is that you can add comments, on the changes you have made. And the support of working in teams.

Good luck.

1 Like


Thanks. I may do that when I can face working through the problem. Unfortunately it’s used up all my patience for the moment :slight_smile:

Right now I’m just committing things and worrying about it later. I save all of my work as versions in the folder anyway (a habit of years of bitter experience), it would just be good to use the SourceTree if it will make life easier.



Hi, @Dan_Marfleet

I think I have the same problem as yours. On the bottom left, I have no folders. Is there any solution?

Here is from mike

And here is mine


To be honest, I just gave up on it. It wasn’t working well for me so I just went back to my old system of Save As and then just giving my models a sequential number.

If memory serves, and it may not, there was an option somewhere that allows you to switch between the view with, and without folders. I don’t think it affects things in any meaningful way, it’s just a layout option.


I have the same problem, the newest sourcetree looks different. I would advise learning to use git through command line as this never changes. I don’t know why the instructors seem to think that using an application is simpler than using command lines.
If you are on windows, you woiuld have to download Git bash that will open a terminal window that will enable you to use git command. The difficult part will be I guess to generate ssh keys for windows but you don’t need that until you push your commits to the remote server.
To work locally, you just need to create a .gitignore file in which you type /reference_material or whatever your reference material is called.
After you can use commands like git status which displays unstaged updated files in red and staged updated files in green
you can use git add . to stage all unstaged files or git add filenamewithpath to stage specific file, the filenamewithpath with be as displayed via git status. typing the whole file name with path is a bit tedious compared to just using dot for all files. You can use git rm filenamewithpath to unstage a staged file but if your gitignore works properly you just need to stage all files in mho
Then you can use git commit -m “name of commit” to commit your stage files.
There are other commands to create branches ot to push to remote server not sure if those are useful here.

Ok I have found the solution. First to display files in tree mode, look at the menu bar above staged files there is a hamburger menu icon , if you click on it you will have display options, select tree views.
But that is too simple, if you have created a reference material folder like me and it is empty it won’t show up in the tree, what I did is create a dummy file in it, an empty txt file. The reason for this is that git doesn’t persist folders it only persists files. So empty folders will be ignored anyway. Problem is that SourceTree ignores it so well that it won’t display it so you can’t ignore it for later when you have files in it. The best solution I know of is a dummy file.

There is another solution if you don’t want to create a dummy file. When you choose to ignore the folder in SourceTree it does two things, create a .gitignore file and then add a line with your repository name in it followed by / so Reference Material/ for instance. the forward slash indicates that you are ignoring a folder not a file. Well you can add a .gitignore file by hand and add the line manually. It sounds easier on paper but windows is not very good at creating files starting with a dot, which are hidden files on linux architecture. You should ignore one of the other folders that are in your tree so that SourceTree creates the ignore file then open it with notepad and replace the folder in the ignore file by the one you want to ignore.

1 Like

Please see this thread

Privacy & Terms