No Patrol Route

Anyone else seeing this?

Ben Easily finds the Patrol Points node like this:

My screen looks like this:

Did I miss something?

That’s because he’s dragging off of the character, not the execution node. When you drag off a type, you get methods suggested that are more in line with the type. Usually you won’t be able to find certain methods without dragging off of a type while context sensitive is on. Try turning that off.

Generally, if you ever can’t find a BP method, try turning off context sensitive before doing anything else. That’s the culprit most of the time.

1 Like

oops! I grabbed teh wrong screen cap. Same question, but now with the correct graphic:

Have you added the blueprint variable? Is it public or private?

This one? If so, then yes.

Ah, my bad.

Can you try downloading and taking a look at our project, you can get to it from “Lecture Code Changes” in Resources on Udemy. It will take you here on GitHub.

Yeah, I may need to do that … I’ve obviously missed a step somewhere … Thanks!

1 Like

Well, retrieving the files from github is more of a task than I was expecting.
I can’t get it to build.

Tried just running the uproject file - get this:
"The following modules are missing or built with a different engine version. UE4Editor-S05_TestingGrounds.dll. Would you like to rebuild them now?

I hit YES.

Runs for a few seconds then get: "S05_TestingGrounds could not be compiled. Try rebuilding from source manually.

I try building from within VS and get 469 errors (or something around that number).

Tried right clicking UE Project file and generating VS files - fails

Any ideas?

Try opening the Visual Studio solution, and building the project from there. If that doesn’t work then try clearing the derived files like this…

  1. Close Unreal and Visual Studio
  2. Delete the following folders: Binaries, Build, Intermediate, Saved
  3. Delete the Visual Studio or Xcode solution file (.sln or .xcodeproj)
  4. Re-open Unreal

Good luck

Finally got back to this (the original problem, not the git download issue).

Found the issue. The “Patrol Points” array was marked PRIVATE. So of course the character couldn’t see it.

I’m back on track now …

1 Like

Privacy & Terms