No "Generate VS project files" and “BuildingEscape could not be compiled” SOLVED

7b_be_urc
unreal-cpp

#1

I just had this problem and saw there was no satisfactory answer on this lecture’s discussion page.

I cloned the BuildingEscape repo https://github.com/UnrealCourse/03_BuildingEscape/tree/8880f0cb42f4fdd7c0a9a8205d6d04de4873126a locally, tried to run the project, but it couldn’t build.

I am on UE4.21, Windows 10, Visual Studio 2017.

I had 2 different problems:

  1. no “Generate Visual Studio project files” option when right clicking on the .uproject file,
    and
  2. “BuildingEscape could not be compiled. Try rebuilding from source manually.” error both when trying to execute the .uproject file and also when trying to open the .sln solution file in Visual Studio and trying to build the project from there (right click on the project (BuildingEscape) in the solution explorer on the right, and from there Build).

The first problem was solved by correctly associating .uproject files to the program that is supposed to open them (it’s UnrealVersionSelector.exe, which is located in the Epic Games installation folder, and not the Unreal Engine editor exe!).
The video in https://forums.unrealengine.com/development-discussion/content-creation/19807-which-program-to-associate-a-uproject-with shows how to solve the issue.

The second was solved by following the instructions of the accepted answer here: https://answers.unrealengine.com/questions/230500/basic-c-template-does-not-compile.html . Basically telling VS where to look for includes (headers) and libraries to link for the project. I then managed to build the project seamlessly from VS!


automatically bumped #2

automatically bumped #3

automatically bumped #4