.NET SDK version 4.6.0 not found and making my project fail to compile

I attempted to create a new C++ Class, but upon doing so i got a compilation error that goes as follows:

ERROR: Could not find NetFxSDK install dir; this will prevent SwarmInterface from installing.  Install a version of .NET Framework SDK at 4.6.0 or higher.

i tried installing the newest version of .NET SDK, using both the website, and the visual studio community installer, however this did not work, does anyone know the solution to this problem, i am using unreal engine 4.25.6

Are you sure you installed .NET Framework which only goes up to 4? As of writing the latest (and probably last) version is 4.8.1, released in 2022.

I just did this, and it didn’t work.

Is it the same error? Would you mind showing it?

same error

And the .NET Framework that you have installed?

well now it’s the latest version, i don’t know which one i had before that.

I’m not asking for what you had. Could you show me what you have installed now.


.NET Framework 4.8.1

I meant through add or remove programs.

what do you mean by that?

It’s only showing me this…

That would imply it wasn’t installed. Are you sure the setup completed successfully?

i just ran through the installation again, very carefully, nothing appeared.

By “nothing appeared” do you mean nothing at all or no errors? i.e. Was there a “successfully installed” window (not necessarily the exact phrasing).


I’d assume it’s installed…

Do you still have problems if you install it through Visual Studio?

Open the Visual Studio Installer, modify, Individual Components then search for it and install.

i’ve attempted to do that before, it doesn’t install that way either

Could you show what versions you have installed in Visual Studio?

Privacy & Terms