My Terminal assets aren't available on screen but are when I press play?

As you can see here I have no assets in my Scene view. They show up when I press play and then work as expected but surely I should be able to see how my game looks before pressing play? Like how it looks on the course video…

Scene view:

Game view:

I found a previously closed thread in which one user replied with “Are all layers set to everything” and mine are set to this so it is not that causing the problem.

Everything: image

It’s possible all that stuff gets instantiated on run time.

Hi Kieran,

First of all, expand the WM2000 game object in your Hierarchy. Maybe there are eye icons on the left-handed side of their names. If that’s the case, they are invisible. Just click on the eye.

Secondly, try to zoom out a bit in the scene window. Also click on the 2D button in the top horizontal menu of the scene window to see if the terminal appears.

Thirdly, click on Gizmos and check if components are disabled/invisible.

Have you already tried to restart Unity?

If nothing helped, I would suggest to update Unity because 2019.1 is an outdated version. 2019.4 is the latest of Unity 2019. Maybe you are experiencing a bug.

1 Like

Thanks, Nina, Turns out the camera was just really zoomed in and once I scrolled out for a while it appeared lol.

I’m glad the solution was so simple. :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.