My tank wont move after lecture 266/267

Hi, I was trying to complete the challange to implement GetWheels() in Lecture 266 and 267. When I finally gave up after hours and hours of trying diffrent things I skipped the challange and copied Sam’s solution but when I compiled I was not able to move the Tank at all. I tried logging out diffrent stuff, retry the whole lecture from scratch, even gone as far as downloading and running Sam’s repository but it just doesn’t work. Has anyone come across this problem ? I am on Unreal version 4.22.3 with Visual Studio 2019 16.2.0. I already spoke with Daniel in udemy Q&A and He pointed out one mistake that was in SpawnPoint.cpp 29 line but even when I fixed that it still doesn’t work. Daniel replied to me that he wasn’t able to find the error so I am here asking for help.

My repository is hosted here: https://github.com/UnrealCourseRepos/04_BattleTank

I found solution to this problem. In TankTrack.h I increased the value of TrackMaxDrivingForce by two zeros and it works. I suspect when the Tank was sliding down the terrain it did not require that much force to move compared to when it sits on the suspension system.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.