My Tank BluePrint has lost connection to its parent class Tank

My Tank BluePrint has lost connection to its parent class Tank. It gives a warning when I try to open it anyway but even then when I go to the parent class it will not allow me to select the Tank class.

I have checked my Tank class is still there and it is. Also I have created another tank pawn blueprint and this worked fine.

If anyone can let me know why the connection was lost and if it can be restored that would be most helpful.

Kind Regards


So after restarting the editor a few times I have found that all my C++ classes except BasePawn disapear every time the editor restarts. Then if I run live coding they come back, but the Blueprint classes that were children of the those classes like the BP_TankPawn do not get there link back to their parent.

After some further testing and research I found an article that said I sould close the project, delete my binaries and intermediate folders then restart it. This forces Unreal to rebuild the code and in my case when it was done my project was working again.

Still not sure why it happened in the first place.

It’s what’s described in the Live Coding Issues lecture, you should just need to build with Unreal closed.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms