My project is buffering when I am pressing the stop button

Once i have pressed play button of my project, the sprites are moving and the project is easily working but once I stop it, my projects starts to buffer and the buffering never stops. the buffering went on for 15 minutes straight when I had to force quit my application. i tried resolving it bu uninstalling and reinstalling, but no change. i even shut down my computer and started it, yet no improvement. i restarted my system as well, no improvement. what could the problem might be please help.


Do you use an antivirus program or a firewall that might be slowing Unity down?

Do you use a computer or a laptop? If the latter, make sure to have the power chord plugged in. Otherwise, your operating system might be running the slow power saving mode.

1 Like

I am using a MacBook. Okay maam ill try it with a power plugged in

Ma’am I tried it using power yet it is buffering. Also, My MacBook is new so I dont think so that there might have been an issue with the RAM speed. Please help me with this maam. I a really passionate about completing my unity course but I am unable to due to this issue

If your MacBook is new, check the configuration. Maybe the power saving mode is active. Unfortunately, I don’t own a Mac, so I don’t know what else you could check.

Which version of Unity do you use? Please let me know the exact version, so I can do some research. Maybe there is a bug in yours.

Screenshot 2023-01-10 at 4.55.26 PM

Also after when the buffering starts, I close my project using FORCE QUIT and when I reopen the project again, my sprite goes missing :frowning:
please help maam

Where did you save your project? And where did you save Unity? And why do you force quit Unity? Does Unity freeze or were you not able to click anything anymore because Unity was still busy?

Is your MacBook fast enough for Unity? Do you have enough RAM and free space on your internal harddrive?

Does this happen for all projects, or just this one?

for every project

please help me out

my projects are saved in a folder that I made. Unity is in another folder. I force quit is because I am not able to click any thing anymore because unity is still buffering.
my Mac has 8GB memory. I have attached a picture about my MacBook specification

Well, I was hoping it’s just this one. Would be easy (easier) to find a solution. Otherwise I don’t know and have to point you back to what Nina said.

Also, after I reopen it after forcibly shutting it down, my sprite goes missing.

Did you save the scene? In your first screenshot, there is a * behind the scene name in the Hierarchy. This indicates that the scene was not saved. If you close Unity without saving the scene, all changes will be lost.

Regarding your problem with the buffering, I did some research and found this thread. I also found this thread where multiple problems are described with the Apple M1 chip. Here is another thread. This answer might be interesting for you.

Please note that I don’t own a Mac, so I don’t know how much of this is relevant for your device.

If the issue persists, I would suggest to download and install the latest stable version of Unity 2022 (test Apple Silicon from the download archive).

If that did not help either, please feel free to ask our helpful community of students over on our Discord chat server.

If nothing helped, please report a bug to Unity via Help > Report a bug (in the Unity Editor).

maam I tried it with 2022 versions yet it is still buffering. I really wanted to learn this course. Thankyou so much maam for helping me out.

I have reported a bug. I will surely inform you after I receive some sort of answer. Thankyou ma’am.

@Maheen_fatma, have you already got an answer by the Unity team?

Privacy & Terms