My model changes when I switch from sculpt to object mode

Hi Everyone, I’m new to Blender and I’m trying to make this model smoother, but when I switch to object mode some of the imperfections I try to fix just come back :frowning: I’m just using an armature modifier and searching around I did the normal flipping thingy but it’s still doing the weird stuff

this is in sculpt mode

this is in object mode (check the wrinkles around the mouth)

can you help me out, please?


“Armature modifier”?

Add bones (armature), which includes weight painting, AFTER you’ve done the sculpting.
If you need to sculpt again, then remove armature, remove all the weight paint maps.
Start sculpting, then when finished sculpting add armature and apply automatic weight.

IF you use smoothing:
Blender sometimes get faces with smoothing turned on/off on the object.
In edit mode, select all faces. Turn smoothing off for them, then turn them on to force all faces behave the same.

Also check if you have normals pointing inside.


You are using 2.79, this is so old now few will recall the ways to deal with such issues that may be related to that very old Blender version. Sculpting had huge improvements since then.

Generally, fix, complete, the mesh first before using any armature.


What I noticed is that if you have an armature with a sub div or multires modifier, that happens. You could try and apply the subdiv or multires modifier then go back to sculpt. Might have to save a copy. But the best way is just remove the armature. Remember to delete all the vertex groups also and remove the armature modifier.


Awesome! I don’t know if I did it correctly, but found a checkbox in edit mode for ‘auto smooth’, turned it off and magicly they are now the same!! thanks a lot!!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms