My Character Has a green outline, help

I’m almost at the end of the character modelling course and I’ve encountered a strange problem.
In object mode my character is outlined in green and my edit controls are not working properly, for example the 3 key , instead of moving to face mode gives me an error “Nothing to remove, Manifold edges not found”.

I scoured the internet looking for solutions:

  1. Character is in a group? Press ctl alt G. doesnt work, my character just disappears.
  2. Character has a Rigid Body? There is no sign of this anywhere. Ctrl A dosnt work.

Please help, this is driving me bonkers, lol

Thanks in advance

1 Like

Screenshots, please. File if possible.
Outline color can depend on your theme so it doesn’t really mean much without some point of reference.


It wont let me upload the blender file, or I don’t know how, sorry
I have the standard theme where outlined objects are orange.

1 Like

You can’t upload files directly to GameDev, you’d have to share them through Google Drive or similar.
Also, take full screenshots please, including outliner and any other relevant settings.

I cannot replicate what you’ve got but the only thing that matches this color in this theme seems to be “Greese Pencil Keyframe”.

That said I’m not 100% certain this is it or how to undo it. I would change about the themes to see if the color changes and try to pinpoint what this outline color actually means then go from there.

1 Like

I am not the greatest with Blender but here are some general tips I have picked up over the years.

This has happened to others because the have hidden or locked objects in the scene. You can reveal hidden objects by pressing ‘Alt + H’ and unlock objects by selecting them and pressing ‘Alt + G’ to clear their location.

If your character is in a group, pressing ‘Ctrl + Alt + G’ is used to remove objects from a group. If your character does happen to disappear, after using this shortcut, this I believe means that the character was part of a group, you can bring the character back by going to the outliner panel, expanding the group, and selecting the character object.

Those are some general tips I have heard before, however more screenshots like mentioned above can definitely help. I hope I am not misunderstanding this.

Also here is a list I found online that might help with your error message:

The error message “Nothing to remove, Manifold edges not found” typically occurs when you try to perform an operation that requires selecting or removing manifold edges, but there are none present in the current selection.

To resolve this error, you can try the following steps:

  1. Make sure you are in Edit Mode: Switch to Edit Mode by pressing the Tab key or selecting it from the mode selector at the top of the viewport. This ensures that you can perform editing operations on the mesh.

  2. Check your selection: Ensure that you have selected the appropriate geometry (faces or edges) before attempting the operation. Right-click on the desired faces or edges to select them. You should see them highlighted.

  3. Verify that the geometry is manifold: Manifold geometry refers to a continuous and watertight mesh without any holes, isolated edges, or non-manifold elements. The operation you’re trying to perform requires manifold geometry to work correctly. Make sure that the selected portion of your character’s mesh is manifold. You can do this by inspecting the mesh for any disconnected or non-watertight areas and fixing them if necessary.

  4. Try alternative methods: If the specific operation you’re attempting is giving you trouble, you can try achieving the same result using alternative methods. For example, instead of using the 3 key to switch to face mode, you can manually select the desired faces by right-clicking on them or using other selection tools in the toolbar.

  5. Reset Blender preferences: If none of the above steps work, you can try resetting Blender’s preferences. Sometimes, unusual behavior can be caused by corrupt or conflicting settings. To do this, go to the Edit menu, select Preferences, navigate to the “Defaults” tab, and click on “Load Factory Settings.” Be aware that this will reset all your preferences, so make sure to save any custom settings or configurations you want to keep.

1 Like

Thank You,

I have applied all the suggestions.
I also closed down and re-opened blender many times.
On the last try, I opened a brand new blender project, and then opened my file from the menu.
The previous times, I double clicked on the file in explorer.
I am back to normal but I lost about 1 hour of work.
It must have been something I did in that last hour.

Thank you for the suggestions


Looks like the mystery of the green outline will remain unsolved. Not gonna lie, I was kinda looking forward to figuring out what it actually was.
Glad your file is working properly again though. GL

1 Like

Glad it got solved, I will say I agree with @VVruba, I was kinda hoping this mystery would be solved, maybe as you go back through, you might do the same mistake and figure it out this time, my guess now that it wasn’t grouping is that it was a keyboard shortcut, glad it solved though.

1 Like

Been following this and spent at least an hour trying to find out the cause of the green line. There is old 2.7 stuff about grouping that does not apply to post 2.8 and collections. So we are all still mystified!


Yeah, the grouping thing only applies to the old blender. Since they replaced groups with collections it’s not really relevant.
I’m kind of boggled with how people manage to run into these issues, if something is so hard to replicate that I can’t actively find how to do it, it’s strange that someone following a tutorial managed to randomly get it.
All I can do now is be on the lookout for this behaviour as I use Blender, maybe I’ll stumble upon it someday.


“Green outlines indicate that the object is part of a group (which you can find out in the object context of the properties panel), you might’ve accidentally hit the ‘+’ button to create a new group.”

But I can not reproduce. maybe a Blender version issue?

1 Like

Can’t see that groups exist any more. Collections replaced them some time ago as far as I read when looking into this.

1 Like

Privacy & Terms