MoveVelocity passed to RequestDirectMove has high Z

I’ve gotten the forward/backward movement working, but not the rotation. I think this is because the Z of MoveVelocity/ForwardIntention is too high. It’s currently at .391. I’ve noticed that when I move the Nav Mesh Bounds Volume up and down, the Z value changes. (If I make the Nav Mesh much lower or higher, Z of MoveVelocity goes up even more, to as high as ~.9.)

Am I chasing a red herring, or is there some trick to Nav Mesh placement so that your path-finding vector Z is closer to 0?

Why do I think this high Z value is breaking rotation? If I put my tank perpendicular to the AI tank, here are my vectors:
LogTemp: Warning: Tank_BP2_1012: CurrentTankForward: X=1.000 Y=-0.010 Z=-0.000
LogTemp: Warning: Tank_BP2_1012: Forward intention: X=0.035 Y=0.339 Z=0.940 <-- I’d expect this to have Y closer to 1 and Z closer to 0
LogTemp: Warning: Intend turn throw: X=0.010 Y=0.940 Z=-0.34

My theory is that with a Z value so low, there isn’t enough throw to overcome the friction. If I multiply it by five, I see fast spinning, but at the current value I see no rotation at all.

(I’ve also set AcceptanceRadius very low, to rule that out as a problem.)


It’s fixed. Z of Movement Vector is now reliably close to 0. After lots of fuss and digging through these forums and messing with settings, nothing seemed to work, so I just loaded an earlier commit, removed my tanks from the map and re-added em from the BP. That seemed to do the trick!

I also set all the tank meshes so they can’t effect navigation, not sure if that helped or not.

I’m having the exact same problem. The tanks from lecture 169 (dot product) move a few meters and stop, or just don’t move at all. In this lecture, they don’t rotate at all. I have the same problem with the high Z value. It’s around 0.9

Unfortunately removing and re-adding the tanks does nothing for me. I’m using 4.18.3 so it looks like they just stopped working after some update.

FWIW, I’m on 4.19.2. My Nav Mesh Bounds Volume has location and rotation of 0/0/0, Scala at 100/100/0.5 (X/Y/Z).

There’s also a Recast Nav Mesh (Called RecastNavMesh-Default) which is created when the bounds volume is created. I think those settings are important as well, but mine are just default. I guess you could try deleting your Bounds Volume and Recast Nav Mesh, then recreating your Bounds Volume?

Please let us know if you figure it out, as I’m sure I could fall back into this trap again!

Privacy & Terms