Missing "TankPlayerController.generated.h"

21_bt_urc

#1

What Was Expected

When you make a C++ class using the Unreal Editor it should generate a “.generated.h” file as well as the “.h” and “.cpp” files!

What Happened

I tried to make “TankPlayerController” C++ class using the Unreal Editor, and I successfully generated “TankPlayerController.h” and “TankPlayerController.cpp”! Though i cannot compile because i have no “TankPlayerController.generated.h”

What I’ve Tried

I looked online for some solution (or a link to download another copy of the “generated.h” file) to no avail


automatically bumped #2

#3

It’s a generated file you shouldn’t be using anything other than the one Unreal generates for your project. Right click your .uproject file and select generate project files.
Also be sure that you do have #include "TankPlayerController.generated.h" as the last include in your TankPlayerController header


#4

Thank you (though it did not help) I went back to my previous commit in sourcetree and re made the classes and it worked fine this time!


closed #5

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.