I just changed /if (_timeInAir > _gravityDelay) / to /if (_timeInAir > _gravityDelay && _rigidBody.velocity.y >= _maxFallSpeed)/ Is that wrong?
Apologies this question got missed but it seems okay to me if it is working and its not causing a problem.
There is more than one way to achieve the same result in coding and as long as its performant then its not wrong