Material Shader not appearing in Timeline

Following along with Grant’s Animation and Rigging lesson and I noticed that the timeline is not showing the Material in the timeline. It works and I can see keying happening in the Properties, just not in the timeline. Do I need to enable something?


I had the same problem, I found you need to click on the Principled BSDF node (the one which shows base colour, metallic, roughness, etc.) in the shader window to get it to display in the timeline. Hope this helps!


I had the same issue and you’re right, we must highlight the principled BSDF before adding a keyframe.

By the way I also found this in the Blender Documentation (maybe useful):


This is good to know, thanks for the help!


Yep! You are right, when I did that it worked no issues! I’ll definitely keep that in mind.


I remember Grant mentioning this auto keyframe trap.

But I struggled with the keyframe display issue for a few minutes, too. I thought the keyframe was not created, when instead it just was not visible because the node in the material editor was not selected.

I think the behaviour is consistent with keyframe display for any property (you could argue that selecting the cube should be enough already, though :thinking:). I just did not realize that I can and need to select the BSDF node.


I found the keyframes were not showing for me. After hunting around I found this check box in the view menu. Uncheck it and hey presto - material keys appear.


To show it in timeline @Sarah_Smith Shows the answer. For the dopesheet you need to click the blue arrow head in the header. For show errors you click the triangle with ! in it. To show keyframes for hidden objects you click the middle icon.
Screenshot from 2023-12-10 10-39-48

1 Like

Privacy & Terms