"Master" not automatically appearing in the "Remote Branch" dialogue

Like the title says, when I try to push to github this is what happens for me :


I am further in the course and already had this issue before but I can’t remember how I solved it.
Typing “master” myself will lead me to this error :

Hi Assa,

Type “master” into the field.

image

Did this work?

If not, change “github” to “origin”.

image

Hey ! Thanks for the reply !

My remote is called github, that’s the only option that shows at the top for me.
And in the empty space I did type master but that gives me the error message that I showed in my previous post.

I tried again two times and it finally worked. I’m not.sure why though as I didn’t change anything. That’s the second time it happened.

And the error always disappear with me just trying again.