Managed to break the texture painting map

So, as I was working on this, I noticed that when I applied the ‘test’ texture my door was still black. I attempted to go back and select it an unwrap everything again, and now I can’t see my UV map faces at all whiles in UV editor. I also cannot paint correct onto my textures at all. I’m extremely upset and cannot figure this out, could someone assist me in how to fix this?

1 Like

You appear to have a blank image so there is nothing for Blender to put on the tower.
Did you remember to save that image file after you worked on it? It does not save as part of the saving of the Blend file, they are separate.
Can you see there is a UV map in the mesh properties UV map dropdown?

1 Like

I believe I have saved the turret color image when it was solid grey, when I draw on it it doesn’t show up on the turret and when I try to draw on the turret nothing happens.

I cannot see the UV map at all right now, and I spent a few minutess looking around the tools but couldn’t find a mesh properties UV map dropdown, could you screen shot a snippet of this for me to look for after I get back from work?
Thank you for your time and trying to help me out with this

This is where they hide!

there is a UV map but I cannot see it. I tried to remove it and re-unwrap it and they still do not appear on the left side of the screen for me to actually see or do anything with.

Your overlays are off.
Click, turn on.
Don’t tag Grant for questions please.

1 Like

Is there a particular reason not to tag them? They made the course, and are usually active and happy to answer questions. Others have tagged Grant specifically before and there’s nothing written that I’ve seen requesting we not tag the teachers.

That was not my issue, I leave overlays on at all times. I did finally resolve the issue though, thanks for trying to help out with different solutions, I do see if overlays are off they’ll be invisible so I’ll be sure in the future to keep note of these things.

Whenever we separated each item they each have their own UV map, and when I tried to re-unwrap them all it simply wouldn’t work. I had to join all of the items back together, delete the existing UV map, and re-unwrap it again. I wonder if deleting all of the individual UV maps would have worked.

I then separated all the items again as instructed and found the painting was working, though I am having to enter object mode and select different ones to work on them, I am assuming that is fine.

Thousands of students if they all did it is why. He is busy making new courses. It is fine to look at work or if we get really stuck! lol.

Well done sorting the other bit out. Yes when they are separate you will need to select the one you are working on.

Yes deleting the other original UV map would have let it work. But also you could have added a new UV map via the little plus to the side.

I may have miss understood but you can select all your objects then go into edit mode select every face and press unwrap and you will have all your objects on one map.

I don’t mind being tagged but generally you’ll get a quicker response from the teaching assistants as they are specifically there for that reason. your model is looking good :slight_smile:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms