Mac users solution: No .unitypackage asset in the zip file attached

Hey classmates using Mac. I ran into an issue trying to unzip the particle assets Rick provided and importing the package into Unity. I spent a long time looking through these discussions and rewatching only to find a solution on my own so I’m sharing in case I can save you time:

Originally when I unzipped the folder it created another folder called Impact VFX. Inside where three folders with gibberish names and contained some .meta and other random file types. None of these could be used in the project.
SOLUTION:
Searching in my Finder for the app which unzips compressed files (for me it is Archive Utility), I opened the app and at the top drop-down menu opened the Preferences (Archive Utility -> Preferences). Here I found a checkbox option which said “Keep expanding if possible”. Turn this OFF so that it doesn’t expand the .unitypackage file into its contents.
When I turned this preference off and unzipped the compressed file that Rick attached, it gave me a ImpactVFX.unitypackage file that I could import to my project and continue the lecture.
Hope this helps someone down the road. Keep up the good work everyone!
JPressley

26 Likes

Thanks for this. I was just experiencing the very same issue.

1 Like

Thanks for the info - been struggling with this for a while now

1 Like

Thank you, for the information. It really helped. I didn’t know what to do with this issue.

Thanks. This really help me out.

Thanks this was a big help!

Dude,

Thanks!

Thank you so much!

Had this issue and low and behold the solution right up on top. Thank you, this did the trick.

Thank you so much! This is really helpful!

Thanks man

Thanks!

Created an account just to say thank you!

Thank you!

Thank you!

Thanks for the tip…worked a treat.

Yes! Thank you!

My first idea when I saw the issue was to come to this forum. Thank you for the tip.

Thanks so much!

Thanks JPressley!