Lost a couple of things

16_th_cu2
terminal-hacker
3d
#1

Somehow, I lost the Hacker detail in the Inspector. When I noticed that, I tried to find a way to “fix” it and totally messed the whole thing up. I had to start over and copied and pasted code back in until I got back up to this current lecture. Below is a screen shot of what it looks like in game play mode. When I started over and imported the package, for some reason, I don’t have the display of the Monitor in Screen Mode. I have scrolled my mouse as far as possible and nothing shows up. Will these two issues be a problem later? If not, then I will just leave it alone because I don’t want to have to start over again. Everything runs fine like its supposed to in play mode.

0 Likes

#2

Hi Penny,

Not sure what you mean with regards to the Inspector detail?

Regarding the Scene view, double-click on the WM2000 GameObject in the Hierarchy and Unity will focus the Scene View camera on that specific GameObject.

Hope this helps :slight_smile:

0 Likes

#3

Hey Rob,

I tried double-clicking on the WM2000 GameObject but nothing happens. And what I mean about the detail in the inspector is the script for the WM2000 doesn’t show the password detail when playing the game and you enter the password screen. It shows up on Ben’s screen and it used to show on my screen back a few lectures before but not now. Hopefully, that’s not a big deal though.

Here is a screen shot of Ben’s display that shows the detail I’m talking about:

0 Likes

#4

Hi Penny,

You definitely should be able to focus the Scene View camera upon the selected GameObject from the Hierarchy when you are in Scene view. You can try testing fairly easily;

  • create a new scene
  • make sure you can view it in 3D mode within the Scene view
  • create a cube
  • create a sphere
  • move the two GameObjects apart by a reasonable distance, perhaps by 20 on the X axis and 20 on the Y axis for example
  • double-click the cube, the scene view camera should focus upon it, assuming it isn’t already
  • double-click on the sphere, the scene view camera should focus up on, assuming it isn’t already
  • by repeating the above you should get the feel of moving between the two objects in the Scene view

Note, you should also be able to use the F key on your keyboard to frame the selected GameObject in the Scene view.

Regarding the Inspector detail you mentioned, and the screenshot, note how the Inspector tab says Debug, I suspect yours currently says Inspector. If you right-click on the Inspector tab you’ll get a short context menu, choose the Debug option, you should then see some of the other details from the class, they appear as the greyed out properties, as per the screenshot you provided.

Hope this helps :slight_smile:


See also;

0 Likes

#5

Hey Rob,

Regarding the inspector detail, I have already had it in debug and it doesn’t make a difference with the hacker (script). I just tried it again to be sure but it doesn’t work. I don’t understand why. I used to see it.

I haven’t tried the GameObject suggestion yet. I will try that in a little bit to see what happens there.

The last few days I have had some kind of computer issue going on with my keyboard. I have been trying to figure out what’s going on with that. I’m hoping it’s not some kind of virus. I keep getting missing keystrokes. The only way I’m typing now is because my husband suggested trying a usb keyboard and so far, that has been working. I remember having this issue a couple of years ago but I don’t remember how I finally fixed it.

0 Likes

#6

Hi Penny,

Perhaps you could provide a screenshot and indicate what you believe is missing compared to the screenshot you provided above from the lecture?

Regarding the keyboard, not sure I can really help with that, missing keystrokes however could be something as simple as something stuck in/under the keys - when I worked in an office my keyboard was often full of crumbs from biscuits/crisps/pastries/sandwiches, quite grim when I write it like that, but those little things tend to build up over time and may be preventing the key from registering. Try tipping it upside down and tapping it, give it a good shake, see what falls out - I claim any small change :slight_smile:

0 Likes

#7

Here is Ben’s

image

0 Likes

#8

This is crazy. It wasn’t showing up before but now, all of a sudden when I’m about to take a screen shot of it, it is suddenly there. All I did was close up the Transform button and then the information showed up: Instance ID, Local Identifier, and the grayed out Level 1 and Level 2 Passwords, Current Screen, Level and Password fields. Weird

0 Likes

#9

Hey Rob,

I just went through the steps you gave me for the display issue. I created a test scene and following your steps, those worked just fine but still no luck with getting the WM2000 GameObject to show up in Scene View.

0 Likes

#10

Hi Penny,

Glad you have resolved the first issue, I’m wondering if perhaps you just didn’t have the view expanded, e.g. the little arrow the expands/collapses the detail etc?

Regarding the WM2000 not appearing in the scene, can you be more specific, what exactly isn’t appearing? For example, does the entire computer screen not appear, does the text not appear? When you run the game can you see the computer screen, see the text, and hear the humming sound effect?

0 Likes

#11

Hey Rob,

Regarding the first issue, I did have the little arrow expanded so I’m not sure why it wasn’t showing up before.

The WM2000 object does not show up in the scene view. Everything works just fine when I run the game including the sound effect. I just can’t see the computer screen object in scene view. All I see is an empty border where the object should appear.

0 Likes

#12

Hi Penny,

Could you perhaps share your project files so I could take a look?

The forum will allow uploads of up to 10MB, if your project files (zipped) are larger than that you would need to use a service such as Google Drive or Dropbox, and then share the URL.

0 Likes

#13

https://drive.google.com/file/d/12DrL7nbSLzt7UX0ll-RmHjYjbugeytDw/view?usp=sharing

0 Likes

#14

Hi Penny,

So I opened up your project and observed the following;

  • project open an Untitled Scene (default Unity behaviour), not WM2000 (obviously)

I opened your Game scene and the Scene view camera was focused on the Main Camera GameObject, this appears like this;

The white rectangle is the Main Camera.

I double clicked on the WM2000 GameObject in the Hierarchy and saw this;

Equally I could have used the scroll wheel on the mouse to zoom out and I would have seen this same view. You can still see the Main Camera as a smaller rectangle on the bottom left in that image.

I opened your Test scene and noted that this didn’t contain the WM2000 GameObject at all.

Seems to be ok from what I can see this end.

0 Likes

#15

That’s weird that you can see it and I can’t. I’ve done exactly what you said to do and all I can see is the outline border of it. As long as it works in game mode, does it matter that I can’t see it in scene view?

0 Likes

#16

HI Penny,

In this project, not really no, although it would probably be worth getting to the bottom of the issue in case this is an issue which plagues every project you create.

On that note, you could create a new, temporary, project and import the WM2000 asset into that and see if you see the same behaviour.

If you do, you could then try a different version of Unity, perhaps you already have more than one version installed? Again, create a new project in that version and see what happens.

Other than that it’s a bit challenging to diagnose when it behaves correctly at this end, unless its a setting within Unity itself that has been changed (hence the suggestion to try a separate version).

I have to say though, in that second screenshot at the very top of the topic it does look like you are either just zoomed too far in, or too far out.

0 Likes

#17

Hey Rob,

I think I will try your suggestion of creating a temporary project and import the WM2000 asset. I will let you know what it comes up with.

Thanks

1 Like

closed #18

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

0 Likes