Loop select not working

Using Blender 2.8 on Linux Mint 19.2. I cannot get loop selection to work properly (i.e., using alt+L-click). I found some directions to go into the Linux Mint window preferences and map move/resize key to . That seems to have the same effect as +L-click, just adds to the selection.

I found other folks saying L-click worked for loop selection. When I do that, with either edge or face selection, it does indeed select a loop - but it picks a different path, going all the way down the side of the pyramid and around, vs. laterally around the four sides. I could understand why it might do that with faces, since they’re still adjoining, but when doing it with edges, they’re not even adjoining edges!

Is this just not the right keystroke combination? L-click just does a fundamentally different type of loop selection? Or is there a preference I’m missing somewhere?

Does anyone have this working with Blender 2.8 on Linux Mint 19.2?

ok, now I’m confused. For some reason it’s working now. I was trying to do the section where you place the two parallel cuts around the pyramid. I was placing the loop cuts, and just tried the normal loop selection (+ L-click) again, and it worked. After a bit of experimentation, the edge loop selection is working now as expected, but face loop selection is still going the “wrong way” around the pyramid (if I had to guess, the selection algorithm is picking the edge pairs with the most adjoining face contact?) So, partially solved, I guess? Anyone know how to change the loop selection method? And as far as the original problem, why it wasn’t working?

Not sure what you want to do or how you model mesh is build, but in object EDIT mode, you use Alt + left click, to select a loop.

Using the lowercase ‘L’ - key, is for select all parts, connected of you current selection.

I’m talking about Blender 2.8 RC1.

1 Like

pretty sure that I said in the problem description, that I was using ALT L(eft)-click

Could you post some screenshots of what you are seeing here.
I think it is applying a loop cut but not correctly as you may have originally scale your cube in object mode and not in edit mode so the scale may need applying.

1 Like

I 100% agree with @FedPete… I’m also not sure what it is you want to do, or more importantly, how you modeled your mesh. Also agree with @Marc_Carlyon - Annotated screenshots beat walls-of-text any day.

I would first see if loop-select works as expected on a new uv-sphere and not my model. Duplicate-verts, subdivided edges… so many things (completely unrelated to your key-setup) that could be causing your issue.

Eh, I see why folks were confused; I went back to reread my post and just realized my bracketed “ALT” did not display at all in the post. So everywhere it says “+ L-click” it should be saying ALT+L-click.

So as suggested I played around with loop selects with a UV sphere. I am able to select both lateral (first photo) and longitudinal (second photo) loops; however, I cannot seem to do it deterministically - if it doesn’t select in the right direction the first time, I ALT L-click around neighboring faces until eventually the right loop gets selected. So I’m able to get there eventually with a UV sphere, but annoyingly.

UV-sphere lateral loop select:

UV-sphere longitudinal loop select:

However, I cannot get a lateral loop selection on a pyramid at all. I am only able to do a “longitudinal” loop select:

I generated this pyramid as follows:

  1. New Scene > General
  2. Delete default cube
  3. Add cube
  4. Operator panel > Size = 20m
  5. Scale Z by 0.05
  6. Apply scale
  7. Go into edit mode
  8. Insets and extrudes
  9. Attempted loop select

EDIT: I finally found the right section of the Blender docs that describes how to do face loop selects… you have to click the edge between two adjoining faces of the loop you want to select. I’m now able to select a ring around the Z-axis, so I guess I’ll mark this SOLVED:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms