LNK1104: cannot open file 'kernel32.lib'

I have tried the previous solutions you have named for these problems, but I still cannot figure out what to do. I have installed and reinstalled VS, and VS code numerous of times. I launched VS code through the Developer CMD. I made sure VS was running through CMD on the bottom terminal. The ‘kernel32.LIB’ is indeed in the folder with the Windows Kits. I also already have unreal engine already installed as well. I am at a loss. I am a complete noob coming to programming and would love some help!

Well that’s confusing. Did you install the Windows SDK separately?

This time, no. During my troubleshoot I tried installing the most updated version, and that didn’t work. So this time I uninstalled and deleted all of the SDK and the VS, and then reinstalled just like the videos were saying.

And it’s now working?

No. It is still not working. I have no idea what else to try…

If you go to the Visual Studio Installer, modify, could you list your Individual Components?

I’m assuming you are looking for the Universal C Runtime, which is installed. I tried installing the Desktop App creator as well since I read in another forum that would help. It did not. Here is what I have:

.NET Framework 4 targeting pack
.NET Framework 4.5 targeting pack
.NET Framework 4.5.1 targeting pack
.NET Framework 4.5.2 targeting pack
.NET Framework 4.6 targeting pack
.NET Framework 4.6.2 targeting pack
.NET Framework 4.7.2 targeting pack
.NET Framework 4.8 SDK
NuGet package manager
NuGet targets and build tasks
Text Template Transformation
C# and Visual Basic Roslyn compilers
C++ 2019 Redistributable Update
C++ CMake tools for Windows
MSBuild
MSVC v142 - VS 2019 C++ x64/x86 build tools (v14.26)
C++ AddressSanitizer (Experimental)
C++ profiling tools
Just-In-Time debugger
Test Adapter for Boost.Test
Test Adapter for Google Test
C# and Visual Basic
C++ core features
IntelliCode
Live Share
Graphics debugger and GPU profiler for DirectX
Unreal Engine installer
C++ ATL for latest v142 build tools (x86 & x64)
Windows 10 SDK (10.0.18362.0)
Windows Universal C Runtime

Yeah that’s definitely strange. Have you tried repairing? Would be weird that fixes it but not reinstalling but you never know :man_shrugging:

I FIGURED IT OUT!!! It was because in the past I was trying a Java language class. While doing this class I changed my Environmental Directories. I restored them to the Windows 10 Default Settings and now it works!!

In case anyone is suffering under a similar problem here is what is supposed to be Windows 10 x64 default System PATH setting:

%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\

Source i found the solution from: https://superuser.com/questions/973153/standard-value-of-path-variable-windows-10/973176#973176

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.