Linked objects not highlighted

Hi all,
I’ve been using Blender for a while now and I’m using v3.4.1
when I use Alt+D to duplicate an object, when going in to edit mode the linked objects are not highlighted.
When I edit the object all the linked objects edit as expected. It is just that they are not highlighted.

This used to work so I expect I have pressed something by mistake without knowing and turned it off?

After several hours on Google I thought I would ask on here if anyone can help.

Many thanks


In Blender, linked duplicates are instances of the original object, and they share the same mesh data. By default, when you enter edit mode on a linked duplicate, Blender highlights all linked objects in orange to indicate that they are linked to the same mesh.

It may be because the “Overlays” option in the 3D Viewport is turned off. Here’s how you can check and turn it on:

In the 3D Viewport, press the “N” key to open the “View” sidebar.

Scroll down to the “Overlays” section.

Check the “Edit Linked” option. This will enable highlighting for linked duplicates in edit mode.

Alternatively, you can also toggle the “Edit Linked” option by pressing the “Ctrl+Tab” keys and selecting “Edit Linked” from the menu.

Hope this can help you out!

1 Like

Thank you for your reply.
I pressed “N” and opened the view sidebar but there isn’t an Overlays section.

I’ve also tried Ctrl+Tab but no luck. All I get is the following.


Thank you for your help

1 Like

I am pretty sure this was changed a while back. So it is deliberate.
Only the one you are working on selects and goes to edit mode. But all linked are affected.

Overlays are a dropdown from the top menu bar. But I do not think there is anything there that will make a difference.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms