Lighting Build Failed

So whenever I try to click the Build option to rebuild my level, I always get an error saying that the “Lighting Build Failed.” I tried to just build the lighting, but even that gives me the same error as trying to rebuild the entire level:

I tired clicking WorldSettings_1 and that does not lead anywhere, it just brings me back to the Editor. Not really sure what to do, any help would be appreciated!

Maybe the output log provides more useful info?

Yes, here is what the output log says, but I do not know what this means:

I tried removing my Directional Light and putting a new one, and I tried to rebuild just the lighting, and it still won’t work. I tried opening a brand new project, and it still gave me the same error: WorldSettings_1 Maps need lighting rebuilt. When I click WorldSettings_1, it just leads me back to the Editor.

Is that the full log? Seems like the reason why it failed would be before the first line in that screenshot.

I think this is the full log when it tried to build the lighting:

Not seeing an actual error there. You could try fixing the warning by adding a lightmass volume into your scene. You can find it in the volumes section.

I already tried that, and it still fails:


Is there anything else I can do to try and fix this?

Not sure, clear the log, build the lighting. Then paste the whole thing.

Alright, here is what the log displays after trying to build the lighting:

Ok so I’ve just noticed that the map it’s talking about is not the one in your screenshot. Do you have another one? I also noticed that the level is unsaved in the screenshot, did you save before building the lighting

So I tried to save it before I clicked Build, and it still gives me the same error. I also noticed that the moment I click Build it does not save the level and it does not save the Map Build Registry either.

As for the map WorldSettings_1, no, I don’t I have another map in the file besides Escape.

I tried creating a new project and placed just one cube in the scene, tried to rebuild the lighting, and it still gives me the same error: “WorldSettings_1 Maps need lighting rebuilt.”

I did however, find a tab called World Settings, do you think anything here can help fix the problem?

Looks normal to me.

Could you zip up your project and send it over? Using File > Package Project > Zip up project and then upload that somewhere like Google Drive.