Lecture 112: Enemy tank dances and flies away after Start is clicked

I have initiated the start event to load the BattleGround level. It does so fine. However, on loading the BattleGround level, the enemy tank dances, spins around and flies away. The physics on the tank blueprint are set. Loading the BattleGround level directly has no such impact. Both tanks fall to the floor normally. Any idea why this would happen? All suggestions are welcome.



i have the same thing happening.

I posted on the Facebook page. Someone said that it is addressed in future lectures. I hope we get there soon. :slight_smile:

Try running the game through the executable (Lec 113). There is no such glitch henceforth.

I’am glad it does not only happen to me i tought there must be something wrong with my tank that i created i blender

Which lecture addresses this problem? Thanks.

Uh! I wait for the addressing then :slight_smile:


Can anyone confirm it’s addressed later please?

Cheers :slight_smile:

I don’t think this fully gets solved, the end state of the section, @ben’s tanks don’t have the best movement either.

It gets buffered down but limitations of the design never fixes it entirely. The only real solution is to branch out and create a suspension system (Check showcase section for a students progress although you will have to do a lot of work yourself)

That was the concern, and then the section would get ridiculously long.

1 Like

Apparently it you add the BattleGround level to the list of levels the problem is solved.

1 Like

The main problem is when the world is created it does not have enough time to calculate the overlapping collision, so you could fix that by Spawning the tanks instead of place them in the world.
In the Level Blueprint use (SpawnActor) node and use the class (Tank) and provide the location on world to spawn.


good solution; I just removed the tank so that the level would spawn a tank as a default pawn, and it worked this way.

I just tried this solution as well, and it works.

All he did was go to Window->Levels, then he dragged the BattleGrounds level into this list, and hit play. Working.

The only problem is that the blank level now has a list of elements from the tank level, including the tank blueprint. This is sloppy, and therefore may not be the best solution.

I also chose this solution and it works fine.
However, a bad feeling remains: Other assets physics are working (I inserted some cubes and spheres and they are all behaving correctly). Also in more complex games, it does not seem good for me to not have the actors in the scene when I edit it.

It isn’t the greatest solution, but I found that positioning the tank a few meters above the ground, then having it fall to the ground once the game starts solved the issue, as that means the engine doesn’t have to worry about calcullating collisions for the first second or two after the game starts.

Also I found a solution where if you make the tanks start with physics disabled then ad a delay on level start for any amount (0.0001 will work) before enabling physics, this will prevent it from glitching out. Something to do with the way physics is setup on level load.

Hi all, i think I found what is causing the issue. At least it solved it for me. Now working like a charm. I think the tank parts were colliding with themselves. Therefore in the tank blueprint you need to set collission preset for all parts except the root (tank body).
My settings for collision preset:
Tank - Physics Actor
Turret - No Collision
Barrel - No Collision
Left Track - No Collision
Right Track - No Collision


Worked perfectly, thanks Artur :slight_smile:

Privacy & Terms