Lasers not firing immediately when pressing the fire button

So I have googled this trying to figure out what the deal is. Every solution I have found hasn’t worked. In the Unity Editor, when I toggle “emission” on, the particles fire immediately (now, after some tweaks), but when I am in my game and I legit HOLD down the Space bar (my fire button), nothing happens for about .5 to 1 full second. Then lasers start to fire. I have turned “pre-warm” on, which helped in the editor, but not in game. Then I tried adding a “burst” at time 0 with count 1 in the emission setting. This again, had effects in the editor, but still didn’t cause my lasers to fire immediately. What do I need to do to get my lasers to fire immediately like Rick’s?

Hi,

Which version of Unity do you use?

Hello Nina! I am using 2020.3.5f1

Could you please share your code as formatted text and a screenshot of the settings and values in your Particle System?

Also try to build your game to test if the issue is also in the build. The game window in Unity is just a preview, which is relatively laggy.