Laggy viewport

Good day,
I’m working on a somewhat large scene and for some reason my viewport became unreasonably slow.
I imported a gLTF model into my scene and due to its poly count (over 200,000 tris), and the need to duplicate it multiple times, I created a collection instance to do so.
And then, boom, laggy viewport. I thought collection instances relieve the memory of some load
What I don’t get is that when I switch over to render preview, everything is buttery smooth but in solid view, everything lags.
Does anyone know what I can do to fix this
Thanks

1 Like

Not sure what you are trying to explain (Sorry).
But, Eevee isn’t only used to do a final render, but it’s also used in other viewing modes.
Maybe, it’s because of this? Eevee uses different techniques (also on memory consumption).

  • Which Blender version are your using?
  • Try to start with a fresh new .blend file, then append data from the old file. Sometimes Blender config gets confused.

It may even be related to your hardware. I think solid view uses the cpu and rendered the gpu.

1 Like

OK my hardware configuration is
Intel core i7 10750H @ 2.6GHz
Nvidia RTX 2060 6GB
16gigs of RAM

The thing bugging me is that every other view works just fine. Rendered view, material view and even wireframe work smoothly but not solid mode
I tried restarting blender and even my computer multiple times, but nothing changed
Any ideas?

1 Like

I’m currently using the latest stable build 3.3.0
OK my hardware configuration is
Intel core i7 10750H @ 2.6GHz
Nvidia RTX 2060 6GB
16gigs of RAM

The thing bugging me is that every other view works just fine. Rendered view, material view and even wireframe work smoothly but not solid mode
I tried restarting blender and even my computer multiple times, but nothing changed
Tried starting it in a new file, but still didn’t change a thing.

1 Like

Just try an earlier version of Blender, it may at least rule out a bug in the version you have.
Or. Reset your Blender to the default settings? Disable any add ons not included with Blender.

The problem is it does not sound like a thing caused by some wrong setting or action in Blender. 2ck tris is not high, it ought to be fine in solid view.

1 Like

Are your preferences ok?

  • Switch engine tipes
  • Use Blender only with CPU! To check if there is a driver problem (See NP5)

1 Like

Alright
I tried placing all my assets into one single collection, started a new blend file and just appended it there
Works fine for now tho.
If any hick-ups come up again, I’ll let you know.
Thanks for the support

2 Likes

Glad it worked.

This type of Blender problem has reoccurred over the years.
In the past, I had some of my own. But with more knowledge, less.

I see it as a user error because it’s beginners (student) related.
Students try out a lot. Experimenting with what this option will do. Or strange (for Blender) unlogical combinations. Leaving Blender is an unrecoverable ‘engine’/‘UI’ state.
Starting again and appending your work, will help mostly.

Have fun!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.