Knight and question I am not sure got it right

So, here is rendered image of my knight…I know its not perfect because on top there are some triangular shapes however these are not too harsh, and I am not even sure it is wrong, so that’s my first question.
Second question goes to my understanding of this lesson so I would like to know if I am right about it…
I started to build a mesh and tried to keep it all squares but it just wasn’t possible, especially with rotated parts after extrusion. And then by mistake I think I got what the sense of edge modifier is…If I got it correctly the sense we need to follow is this: we need to open two 3D view windows. On one of them we have our mesh in object mode, and on the other side we have it either in rendered mode or edit mode. When we turn of modifiers there are blue parts in edit mode, but if we want to get rid of triangular shapes what we need to do is on first 3D view (the one with object mode) turn on the smooth function. After turning on the edge modifier the triangular shapes on rendered model (or in edit mode) disappear?

1 Like

That looks fine to me, you have all the quads of the knight looking flat without being triangulated :smiley:


Hello Michael. First of all, it’s a great tutorial!
Now, since i am on the same topic and am currently facing the same scenario(blue quads, indicating Triangulation), i was just wondering if the blue indicators are to be ignored?
Besides, i noticed that if i applied the edge split modifier, and then went in edit mode, the triangulation wasn’t gone. So, isn’t it that the edge split modifier is only making the figure look non planer, and not actually making it?
Thanks in advance.


I have also attached a couple of images of the unfinished design, one in rendered mode and the other in edit mode with the Mesh Analysis enabled.

Knight screenshot2

That’s right the edge split modifier does exactly that.

I would not recommend applying the modifier as it literally tears each quad into its own little piece of mesh.

If you have a look before and after at your polygon countYou will see it has gone through the roof because of this.

In general I would recommend applying modifiers unless you really need to as they are there to increase speed of modelling and allow you to rapidly change your model if you need to without having to modify a ton of geometry

Thank you for the clarification, Michael. But, can you tell me if there is any way to fix the blue quads in this case?

The blue is more of quick visual clue that a face is non-planar and therefore might have undesirable artifacts when rendering.

The real proof is when you render and the knight doesn’t have triangles showing. :slight_smile: just popping the view port into rendered mode will do.

Thanks a lot, Michael:slight_smile:

Privacy & Terms