Keeping Components on Blueprint

Not sure if this has been asked yet, but every time I close the editor and relaunch I have to always reattach the C++ Component back on the Camera Component. And the only way i can do that is by running the Live Code after its restarts. It’s becoming a little annoying and was wondering What is causing this issue?

2 Likes

Please see the lecture regarding Live Coding in Obstacle Assault.

1 Like

That lecture deals with recompiling with code that didn’t save, this is more of a component not staying attached sort of deal. I’m leaning towards it being a problem with the Blueprint that we are attaching the component to and it not keeping the actual component on itself, but I’m too new at this and inexperienced to know. All I know is that doing the section on adding blueprints nodes with the C++ class is a huge pain because regardless of what I do, the component auto-removes itself everytime I close the editor and I have to go back in, reattach, delete the old blueprint nodes, and readd them.

I’ve seen several students saying that they had that problem too and was fixed by disabling Live Coding. Did you try it?

I have not, I will give that a try shortly. But if I disable Live Coding, does it need to stay permanently disabled for the rest of the course? Sam mentioned that hot loading is quite tedious and can delay the project, so I’m just curious if I need to keep it off or disable/enable. Thanks!

For the record I haven’t had any issues using Live Coding with VS 2019 for the course content. However, if you find that your project continues to end up in a bad state after compiling with LC, you might just want to stick with compiling straight from VS or VSCode. Disabling LC isn’t required to recompile with VS or VSCode, btw.

Also, Hot Reloading is basically deprecated at this point (meaning it is unsupported and will eventually be removed from the engine) so I personally wouldn’t recommend using it as a fallback for LC.

Was also experiencing this issue. Think its solved for me now… after I’ve closed out of both Visual Studio 2022 and Unreal Editor, AND deleting \Intermediate, \Saved, and \Binaries folders from project root folder… and then opening Unreal Editor again.

Recompiling from source… the Blueprint for BP_Player still had the Grabber C++ component as child.

1 Like

I think you are on to something here. I disabled the auto save feature in Unreal because it was popping up too often and was only saving like instances of the project and not the actual project. When I did that and went into the file explorer location and deleted the AutoSaves folder and relaunched it was staying attached after I added it through Blueprint. It might be a bug. I had googled this problem too and some people in an Unreal forum were stating a similar problem with no fix.
Good catch

deleting \Intermediate, \Saved, and \Binaries folders from project root folder… and then opening Unreal Editor again

FYI - You also need to right-click the .uproject and select to re-generate the visual studio project files (since deleted with the \Intermediate folder).

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.