Issues with undefined nodes in WizardsChambers.blend

Some of the Nodes in several of the materials in the WizardsChambers.blend file display as “Undefined”.

I’m using version 3.5.1 and have tried opening the file with versions 3.01 and 4.0 but the problem persists. See the screen shot.


Never seen this!
It can be that those “undefined” node, differ in more Blender versions.
You could import it in Blender 4.x and then replace those nodes with actual ones.

maybe that helps?

Can you say which course and lesson this is occurring?

1 Like

The course is “Blender Material Nodes Mastery” and the file is “WizardsChambers.belnd”.

After a bit of research the issue seems to relate to the older blender version “Mix RGB” nodes, which in later versions have been replaced with the more universal “Mix” nodes. The later versions of blender don’t know how to interpret these obsolete nodes.
I managed to correct the “Flagstones” material by replacing the undefined nodes with “mix” nodes by watching the course video.

The problem with doing this for the other materials is that some of the mix nodes while all being “Color” varied between: Multiply, Add, Color Dodge, & Linear Light, and the course material doesn’t go into detail about all the other materials, so I don’t know what the replace them with.

I work with blender version 3.5.1, but I’ve tried the latest version 4 and version 3.0.1. I had hoped to open the file in v3.0.1 to see what the Mix RGB nodes were doing so I could replace them, but I got the same error. Older versions won’t run on my system for some reason.

Hope you can help.

1 Like

Managed to get blender version 2.82.7 working on another PC. Sadly, I get the same result.

1 Like

Those color mix options are very generic. You can look them up.
For this node setup, I can not help. Because I need to know what it will do.
Or what the end result should be. Maybe someone else.

I would chose to work with the latest version. And cope with the problems. It’s all about learning, and not getting a bunch of nice materials, which can also be found on the web.

Version 3.5 is old. Geometry nodes in particular are for ever updating. I would first get the same version as used in the lectures.

Weird the course is in 3.5 so 3.5 should work. Try open it in 3.6.8 Blender 3.6 The LTS versions are made to be forward and backward compatible between LTS version. So 3.6 should be able to handle from 3.3 thru 4.2 or 4.3 which ever is the next LTS. As long as it’s the latest sub version. Which is currently 8.


Are you using 3.5.0? If so try updating to 3.5.1


Version 3.5.1 is the version I’m using (same as the course version). I downloaded version 3.6.8, but I got the same result. I’m just going to have to work out how to fix this issue by experimenting with the various Mix nodes. Thanks for all your help anyway, it’s nice to know I’m not alone.


I think you may have a corrupt file. I just downloaded it, unzipped, and opened it. This is the stonework in 4.0.2 that you screenshot.

This is it in 3.5.1.

I’m running Linux Mint 21.3 Cinnamon DE 6.0.4. I don’t think that would make a difference.


Sorry to take so long to get back to you, I have no idea why those nodes aren’t showing up, despite being the correct version of Blender.
I’ve also tried the file in a few versions of Blender (older, and newer) and no undefined nodes appeared for me, either with the original file, or a newly downloaded version.
As far as I know this is the first time the issue has been reported.
They are all Mix color color nodes, although the blend types are different.
If there are certain materials you are particularly interested in I’d be glad to screenshot though entire node trees for you so the undefined nodes can be replaced.


You might be right, I’ll try downloading the file again.


Stephen, I’m going to try downloading the file again. Great course by the way, I’m going through it as I work on my book cover. The more I learn, the more changes I make.


Dwayne was correct, it was a corrupt file. Another download work like a charm. Thanks for all the help.


Great thank you for letting everyone know it was a very strange one.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms