Issues with cinemachine package manager importing

Greetings. Loving this course and all this website. I’m having issues when installing cinemachine through the package manager. Here is what it says:


Can’t say everything is working properly, but so far so good though. Someone has an idea of what this error is?
Cheers :slight_smile:

Hi,

Which version of Unity do you use? Where did you get the cinemachine package from?

In your screenshot, OneDrive is mentioned. I hope this is a normal folder on your harddrive and not managed by any software or let alone a folder on the internet. Unity and the project folder must be on a normal harddrive.

1 Like

Hi Nina, thank you for your reply. It is managed by one drive, but all the projects and unity itself are fully installed on my hard drive - the latter is not even on onedrive. I never had an issue like this, so I thought it wouldn’t be a problem. I’m using the 2019.4 version of Unity and I got the package straight from package manager. What should I do? Do I keep working on the project normally or reset to the version without cinemachine and try to installed without erros?
Cheers :slight_smile:

It might be that OneDrive deletes files or restricts the access for Unity. That’s why it is not advisable to install anything in a cloud system or any other managed folders.

Is there a reason why you are using Unity 2019 instead of a later version? If not, make a backup of your project and install the latest stable version.

1 Like

Alright then, I will try to import the package with a clean unity install and will remove my projects from the onedrive sync. I’m using the 2019 version for an assignment, so I really don’t have much of a choice. I’ll reply here if everything worked out or not. Thank you for the help!

How are you getting on with this, @Rafael1?

1 Like

Greetings, Nina. Thanks for keeping in touch. I solved the issue: apparently it was a directory path that was way too long. This long: C:\Users\rmper\OneDrive\Senac\Projeto Integrador\PI 2\Jogo TCC\Projeto Integrador. I copied a version without cinemachine in a much shorter path, reinstalled it and had no issues whatsoever.

Hope this helps with future similar problems :slight_smile:
Cheers.

Good job on solving the problem, and thanks for the update! :slight_smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.