Issue with moving Pins up

In Ben’s code he translates the pins in the Y direction to move them up, but in my code I have to translate the pins in the Z direction to achieve the same effect. My code makes sense since we did have to translate the pin 90 degrees. Therefore the axes should be flipped.
Why did translating in the Y direction actually move the pins upward for Ben?

Hi @Braxton_Dubin,

To check if there is a problem with your pin Y/Z Axes, make sure the “Local/Global” button is set to “Local” and select a pin - Your pin should have the GREEN (Y) arrow pointing up (or coming out through its top if rotated). If this is this case, check that you’re moving the base object, and not a child.

Possible Fix (IF you feel like it); PLEASE BACK UP YOUR PIN BEFORE TRYING TO “FIX” IT (juuuuust in case I don’t know anything):

1.Make a “Container Game Object” with a “Reset Transform” (Empty Game Object with Transform = 0,0,0 Position, 0,0,0 Rotation, 1,1,1 Scale).
2.Move Pin RigidBody, Script, and AudioSource to this object.
3.Rotate Pin_Render & Pin_Collider -90 degrees on X-Axis.
4.Child the Pin_Render & Pin_Collider to “Container Game Object”.
5.Update any outdated Script References.

This should HOPEFULLY work.

It seems there may be an issue with your pins’ Y/Z axis.
From my very limited Modelling experience (Read: “I heard this from a guy / Saw it on Youtube / Read it somewhere”, etc.), Modelling Software can have different “up” axes.

Next to the selection/manipulation tools on the top left of your editor, there should be 2 buttons. “Button 1” will say “Center” or “Pivot”, and “Button 2” will say “Local” or “Global”.

“Button 1” dictates where the object is manipulated from; if the object has its pivot set somewhere besides the center (such as a humanoid character, or say, BOWLING PINS :wink:), then you can move and rotate them from the pivot, rather than at the center.

“Button 2” dictates which coordinate system you use to move an object. World moves all the objects the same way, and is personally my preferred setting. Local moves objects in their local space, such that you move them as if they’re on poles based on their rotation (e.g. moving forward on Z may have different behavior in Local mode if there is rotation).
This is important if you get a model that doesn’t have “Y = Up, Z = Forward” etc.
See above for possible fix if you have the problem I think you do.

Sorry if this is all stuff you know already; Hope this helps :slight_smile:

And PLEASE, someone correct me if I’m wrong. :confused:

1 Like

Thank you!

Privacy & Terms