Issue exporting to iOS

#Godot Version v4.2.2.stable.official [15073afe3]
Apple M2, macOS Sonoma 14.4.1

I’m trying to do the export to iOS on a Mac. I usually use windows and I’m not very familiar with the Mac. I setup a free team ID and I’ve plugged my phone into the machine.

I’m getting the following error message in the output log:

editor/export/editor_export_platform.h:182 - Xcode Build: Xcode project build failed, see editor log for details.

I presumed that if I looked in this log it would give some clue as to what I’d done wrong.
I thought at first it would be in the projects log directory as in ~/Library/Application Support etc, but after overcoming the issue of it being in a hidden directory, I found that the export process doesn’t appear to update anything there.
Does this “editor log” exist somewhere, or is it just referring to the output window?

A lot later on in the output window (right at the end) it does say that it couldn’t find a device or provisioning profile for my team and I should plug one in or configure it, but I haven’t been able to figure out how to do the latter (and it’s not been mentioned as being necessary), and my phone was plugged in and I’ve tried unplugging, re-plugging etc and it made no difference. I’m not sure if this latter error is because half the files in the directory it creates are missing by that time or it’s the underlying issue.

Any thoughts.

Hi Baztak,

As i dont own a Mac its a little difficult for me to find the issue but i had a dig around and the only thing i can find really on this error is a possible error in the apple store id.

Blockquote If anyone has this issue, this is due to the wrong App Store Team ID. Make sure to use Organisational Unit id number and not anything else. There are lots of confusing numbers in the Keychain Access app.

Not sure this is even related to your issue but its something i would check. The link to the post is below

Thanks for looking.
I’m pretty sure I’m using the organisational unit id number from the keychain app.
I think the problem is probably that I set it up using the Exporting to iOS using Godot 4.1, for free | by Phillip T. George | Medium which is mentioned in the course, rather than paying for and having access to the team “Certificates, identifiers and profiles” page. The original run of the course said you needed to sign up/pay and this information about doing it for free is a tag on to the course.
Perhaps with specific phones/iOS versions, XCode versions, hardware etc then it might work, rather than it working as a global solution - I get the impression that Apple doesn’t want people to be able to try it for free, they want there annual fees.
(PS I also tried it using Godot 4.1, it gave an output more inline with the one in the issue you referenced)

Yeah personally i hate things being hidden behind paywalls which is why we try to avoid making courses that require them.
Unfortunately if something is outside the course and i havent personally used it then my support is very limited in the help i can give you.
It might be worth trying the way we do it in the course and see if it works that way and rule out an issue in the code and confirming its the linked resource and it being the free version.

Hope you get this sorted

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms