Is this a glitch in the normal map?

Hi guys, I tried different numbers for ray distance and extrusions but I couldn’t fix the normal map, is this a glitch that has to be fixed in photoshop, or is this a problem caused by mark seams?

Also, the glitch bleeds into the mesh, this hasn’t happened to me before, is there a way to fix this?

1 Like

It does look related to the seam by where they are. I wonder if it is more related to the margin given in the bake to each island in the UV?

Just check for flipped normals too.

The margin in baking is 16, it works fine with other islands, only happens with the feet in the photo.
For flipped normals, do you mean face orientation? It’s all blue.

It is the seam glitching I think. I fixed the seams and the problems always occur with seams, most textures on the normal map don’t connect for some reason.

While some parts seams are very smooth

Is this a new problem from 2.91? or is it cause by retopology manually? I didn’t have this problem when I use retopology automatically in 2.9.

1 Like

Check your normals!
They need to point outside.

The eyes are not symmetrical. You need to fix that by hand.

You can delete one halve of the mesh and use an applied mirror to copy it back.

Could you show me how to point and check normal outside?

The parts that got glitches are the back of the foot, I also used mirror before mark seams and unwrap, I don’t follow you about the eyes, could you explain a bit clearer?

1 Like

Checking normals is basic Blender knowledge, explained earlier in the course.

One way to check is

The mesh loops around the eye are different.

Right side is fine, left is wonky …


FIRST I would check if the normal map is actually working correctly.

This post on stack exchange gives a good visualization of how normal maps look when viewing the color data as if it were a color map. This can be misleading.

So, if you add a solid colour to the model and check how the light behaves on its surface (instead of looking at the normal map) can you still see a seam?

Most normal maps in any program look this way and perform perfectly fine when not looking at the normal map colour.
The reason for this is because the normal map is 2D and so the information is translated from 2D to 3D.

SECOND (if the problem persists)

However, just to be safe check these settings here before baking:

If the seams are still visible and the problem persists, you could try this:

Smoothing the vectors of the normals will average out the normals of the vertices based on the closest vertex. Sometimes UV seams can cause edges to become hard so this can help sometimes.

I hope that sheds some light on the issue and I hope you find a solution if there’s a genuine problem.


Wow, adding the solid color actually works wonderfully for me, the seams are gone. Thanks a bunch!

But the back feet glitches still persist

here too

Do I fix it by painting or is there a better way to fix it?

Normal maps are not colour maps but data maps so there’s data there that you corrupt when you try to paint it. They can be painted, it does “fix” issues but there’s usually a better way. Painting it is never 100% accurate and it takes longer.

To get the best normal map, I’ve found that using a cage gets the best results in almost every circumstance.

To make a cage, simply duplicate the retopologized character mesh. -> “Shift+D”

Rename it to something like “CAGE” -> “F2” This opens the renaming dialogue box in the viewport.

Go into the cage’s Edit Mode and press “Alt+S” to scale it along the normals. This needs to just be big enough to completely cover all parts of the high polygon model/sculpt. Be mindful not to change anything of the geometry or the cage will be invalid (no adding or deleting faces).

Then under the bake settings, turn on the cage checkbox and select the new duplicate.

The Max Ray Distance is now not necessary so it can be set to 0 if you like.

So the instructions again for creating the cage but simplified.

֍ Select the retopologized mesh.
֍ Shift+D              (Duplicate it)
֍ F2,                  (Rename it) 
֍ Tab to Edit Mode
֍ A                    (Select everything)
֍ Shift+A              (Scale until it covers every bit of the high poly).
֍ Exit back into Object mode.

I hope that helps!


That is interesting, I only use baking a little and always use a cage it just seems easier. Though most tutorials seem to try to avoid it strangely.

I suspect it will be a difficulty with the close ‘tucks’ on a character though.

Thank you very much, this helps a ton.
I have heard of cage but seeing most people use non cage so I just go with it, didn’t know cage would be this great!


Glad I was able to offer some useful info :slight_smile:


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms