Intellisense not working

My Intellisense does not work properly with this project. It does not recognize the variables I declare in the header file and it has no suggestions when I try to use the Intellisense with FVector and the scope resolution modifier. The Intellisense doesn’t work when I tried to type out SetActorLocation and the like. It shows stuff when I type “UE”, but not anything that we have been using in the course up until now.

2 possibilities here. One is related to live coding (refer back to lecture on this in the crypt raider section) and the other is related to the project refresh option in the tools menu of unreal which updates the workspace.

I’m not familiar with VS code but the issue is a common one regardless of editor and this often fixes it.

Let me know how you get on.


I have refreshed the project many times. I even refreshed after deleting the Binaries, Intermediate, and Saved folders as was suggested elsewhere; however, this has not helped. Could you direct me to where exactly the “crypt raider” section is? It is not ringing a bell.


Sorry, I made a mistake. It is in the obstacle assault section and talks about disabling live coding but it doesn’t seem that is the issue. Try hsving a look here and see if this works.

I tried adding in the includePath, but that did not help. I’m on an MacBook Pro M3 Max.

Sorry, I don’t have access to any apple hardware so this is pretty much all I can do at this point.

I was asking around in some UE support places and they basically told me don’t use VS Code on a mac. I know it can work but apparently it is a little broken. They suggested using XCode or Rider (not free) as that’s about the only available options for a Mac.

I know you can get it working but I actually don’t use VS Code myself for this very reason.

Thank you for the reply. I’ll have to re-evaluate :stuck_out_tongue:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.

Privacy & Terms