Insetting

hey guys i don t really understand why my inset is diiferent from our techer when i select “1” value for thickness it is to small blender is in "metric"mode by default on my ui is this the way ? What value our teacher selecting ? ty

Thanks pete !

Provenance :
Courrier
pour Windows 10

I have the same issue! when I set up my cube I typed in “20m” for the x and y but it is still insetting like a
Alain shows. Do I have to change my cube to different dimensions for me to be able to inset with 1?

Well change the inset amount to 0.1 not 1.

As FedPete has said, insetting 1m takes every edge to the centre of a 2x2 square.

Offset even box not relative checked.

If you made a 20m cube, insetting 1m works. If it does not for you check that the cube you made actually came out 20m not 2m? You can use the measure tool on the left hand menu.

Let me know if this doesn’t look right. I just don’t understand why when I try to inset one it doesn’t work because the dimensions does say it is 20m. Its not a huge deal, it just doesnt make sense to me

So just to try and get the pyramid done, I did what you said, which was inset at 0.1 instead, so I did. But then when I extrude by 1, it works just fine. I don’t have to extrude by 0.1. This is very inconsistent and I am not sure why…

Its very hard to diagnose what the problem was for you from one snapshot, in layout, object mode. Though it does show that is 20x20m. Inset 1m should work.

This is a 20x20m by1m tall base, inset 1m. It works. I left the operator box up too so you can check if you have differences. Check my being in edit mode, face selection views. I can’t replicate your previous problem unless the size was wrong without you realising it.

How did you scale …

  • Scale the object
  • Scale the mesh of the object

Object en the mesh of the object are different things!
If you scale the object you need to apply the scale. Select the object, then press Shift+a, select apply Rotation & Scale.

3 Likes

Pete! This is why it was not working! Thank you so much. Amazing what confusion comes from missing one little step…

2 Likes

I found I had to inset by .1 instead of 1 unless I applied the scale first. Probably because I scaled in object mode instead of edit mode. So, if you scale in object mode first, you have to apply the scale before doing the “i-1-e-1” steps.

2 Likes

Aha! Came here for same issue, found the solution :slight_smile:
Great little forum!

1 Like

Thanks @FedPete and @ajollynerd, for reminding us! I was just noticing that when I was performing the insert, the depth of the insert was being calculated based on the original size of the cube, when I performed the Shift+A -> Mesh -> Cube operation. If I started with a cube that had a size of 20m and a scale of 1.0, using 1m for the offset worked. However, if I started with a cube of size 2m, scaled it up by 10.0, using an inset of 1m was way too much.

I noticed that inset was being calculated from the object’s original dimension, with no regard for any scaling I performed on the object, and it was ignoring the new calculated dimension (displayed in the transform panel under Dimensions:), which is the resulting dimension of the object, based on the original size multiplied against the scaling values I changed.

Now I remember, way back in an earlier lesson how they showed us how to apply those scaling changes to the object, while in Object Mode, and how it maintained the currently calculated dimension, and reset the scaling values to 1.0.

After performing the “apply” (Ctrl+A) operation to Rotation & Scale, using inset with a value of 1 worked as expected. That’s an interesting nuance, thanks for shedding some light on it!

edit: This is embarrassing, after re-watching the section about how he makes the pyramid, he explicitly said: “Now we have 2 options, we can do it in object mode and apply, or we can do it in edit mode”
Hah! I need to pay closer attention :stuck_out_tongue:

1 Like