Input to PlayerInput name change

At the start of the lecture Input was changed to PlayerInput in the .cpp file

void UBullCowCartridge::OnInput(const FString& PlayerInput)

Why did we not need to change that in the header file as well?

	virtual void OnInput(const FString& Input) override;


The names for parameters in a declaration aren’t used at all, you don’t even have to provide them. It does come up in IDE’s so it’s nice to give them descriptive names. Seeing

void Foo(int, int, bool);

Come up in a tooltip is not helpful.

So Input is never used there and it’s descriptive enough.