Input Component is not Present in Defaultpawn_BP

As soon as i use the “if (InputComponent)” statement to run my grab and release code block it doesn’t work. So i tried logging out:

if (!InputComponent)
UE_LOG(LogTemp, Warning, TEXT(“input component is not present
on %s”), *GetOwner -> GetName)

to see if the input component is actually present. The code within the if statement ran after compiling and to double check i ejected from the DefaultPawn_BP and selected it in the world outliner to see its properties. The Input component was not present, in the lectures i learnt the input components were meant to be added automatically to my blueprints. I’ve tried manually adding the input component but its not even appearing when i search under +AddComponent. Please what can i do?

I’m not sure which course you are working on but I am positive you will have a better chance of getting the help you need if you move this thread to the appropriate forum.
we don’t do much with programing in the blender courses :slight_smile:

Oh, wow, i’m sorry, i did not realize this was blender’s forum

Dupe Input Component not present on my defaultPawn_BP

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

Privacy & Terms