Importing tank fbx doesnt work as intended

12_bt_urc

#1

When I import the fbx files, they don’t import correctly – all the pieces are broken up. There’s 20+ meshes here that aren’t put together instead of the 4. I don’t know how to put the tank together with 40 meshes lol I guess I could try though. Just seems like a lot more work than Ben intended.

Any idea how to fix this?


#2

Can you show a screenshot?


#3

Sure. I managed to fix it by importing the uasset files from the github. Maybe it’s a 4.15 issue as that’s the version I’m using.


#4

I am also having this same issue. Rather than just importing the four .fbx files for the tank, Unreal is breaking them down into the individual meshes as @oscarkool has shown above I am using Unreal Engine v4.15.0.


#5

Temp fix is to just go to the Project Files and download the 4 uasset files and move them into the folders manually. They’ll show up as the correct FBX files so you can continue the project.


#6

Thanks for that update. I was somewhat stuck trying to figure out if there was a setting I missed. Might just be a new setting with the current version of Unreal. Will download the assets for now, but very curious to see if someone has an answer for future imports.


#7

By default with 4.15, combine meshes is disabled when importing. So just tick that on the import menu and it should work.


#8

Thanks for the update, that was the setting I was missing.


#9

Thx for the answer


#10

Thanks, that ‘combine’ option worked for me also! Yay. Onwards with the learning.


#11

Perfect! Thanks for that option hint! (But also good to know you can break them down if you want to!)


#12

It’s actually tempting to import the individual meshes uncombined in a separate directory, put them together, and use them as pieces to “blow up” a tank…


#13

Thank You. I was Having the same issue. Checking the box worked. Thanks again


#14

This answer is still very helpful, thanks.